aboutsummaryrefslogtreecommitdiffstats
path: root/net/rwhois/Makefile
diff options
context:
space:
mode:
authorjfitz <jfitz@FreeBSD.org>1997-05-31 04:13:24 +0800
committerjfitz <jfitz@FreeBSD.org>1997-05-31 04:13:24 +0800
commitd4c1d3f4dcab2fdd2ca4e548e39e0594d5c2ded1 (patch)
tree1cb126fd3df74c9079ecf0d2ef2496aff33b2777 /net/rwhois/Makefile
parent3843993d0ac401a73d0fa9f340e3bf0dd781b009 (diff)
downloadfreebsd-ports-gnome-d4c1d3f4dcab2fdd2ca4e548e39e0594d5c2ded1.tar.gz
freebsd-ports-gnome-d4c1d3f4dcab2fdd2ca4e548e39e0594d5c2ded1.tar.zst
freebsd-ports-gnome-d4c1d3f4dcab2fdd2ca4e548e39e0594d5c2ded1.zip
Import of the InterNIC's referral whois server and client
Diffstat (limited to 'net/rwhois/Makefile')
-rw-r--r--net/rwhois/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/rwhois/Makefile b/net/rwhois/Makefile
new file mode 100644
index 000000000000..afdd2b468c92
--- /dev/null
+++ b/net/rwhois/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: rwhois
+# Version required: 1.0b9.2
+# Date created: May 9th 1997
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= rwhois-1.0B9.2
+PKGNAME= rwhois-1.0b9.2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.rwhois.net/pub/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+HAS_CONFIGURE= YES
+CONFIGURE_ARGS= --prefix=${PREFIX}/lib/rwhois
+
+LIB_DEPENDS= wrap\\.7\\.:${PORTSDIR}/security/tcp_wrapper
+
+INSTALL_TARGET= install install-sample-data install-chroot
+
+MAN8= rmkdbindex.8 rwhoisd.8
+
+post-install:
+ ${MKDIR} -p ${PREFIX}/share/doc/rwhois
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/rwhois
+ ${MV} ${PREFIX}/share/doc/rwhois/rmkdbindex.8 ${PREFIX}/man/man8
+ ${MV} ${PREFIX}/share/doc/rwhois/rwhoisd.8 ${PREFIX}/man/man8
+ @ echo "Installing ${PREFIX}/etc/rc.d/rwhoisd.sh startup file..."
+ @ echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/rwhoisd.sh
+ @ echo "#" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
+ @ echo "" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
+ @ echo "# remove or comment the following line and uncomment the one below it once you have" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
+ @ echo "# configured your server's data" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
+ @ echo "echo \"rwhoisd not started; sample data still in place. See ${PREFIX}/share/doc/rwhois for details.\"" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
+ @ echo "#[ -x /usr/local/lib/rwhois/sbin/rwhoisd ] && /usr/local/lib/rwhois/sbin/rwhoisd -c /usr/local/lib/rwhois/rwhois.conf & && echo -n ' rwhoisd'" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
+ chmod 751 ${PREFIX}/etc/rc.d/rwhoisd.sh
+
+.include <bsd.port.mk>