aboutsummaryrefslogtreecommitdiffstats
path: root/net/rwhoisd
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>1999-06-27 06:58:41 +0800
committermharo <mharo@FreeBSD.org>1999-06-27 06:58:41 +0800
commit9baf821d3988f6cd5c78b45b3bb1de74a1ae355a (patch)
tree4e985c310a2fccb74aecf5f34c2e2d4ebb243499 /net/rwhoisd
parent359443d490e9ea78e97cbe34e40a0d24fdceb088 (diff)
downloadfreebsd-ports-gnome-9baf821d3988f6cd5c78b45b3bb1de74a1ae355a.tar.gz
freebsd-ports-gnome-9baf821d3988f6cd5c78b45b3bb1de74a1ae355a.tar.zst
freebsd-ports-gnome-9baf821d3988f6cd5c78b45b3bb1de74a1ae355a.zip
use ${PREFIX} and only require tcp_wrappers if it isn't part of the
base system.
Diffstat (limited to 'net/rwhoisd')
-rw-r--r--net/rwhoisd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/rwhoisd/Makefile b/net/rwhoisd/Makefile
index 77fc35ae698e..827473d32be7 100644
--- a/net/rwhoisd/Makefile
+++ b/net/rwhoisd/Makefile
@@ -3,7 +3,7 @@
# Date created: May 9th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.4 1998/10/14 00:19:56 jseger Exp $
+# $Id: Makefile,v 1.5 1998/10/16 03:10:09 jseger Exp $
#
DISTNAME= rwhois-1.0B9.2
@@ -13,7 +13,9 @@ MASTER_SITES= ftp://ftp.rwhois.net/pub/
MAINTAINER= jfitz@FreeBSD.ORG
+.if !exists(/usr/include/tcpd.h)
LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
+.endif
HAS_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX}/lib/rwhois
@@ -33,7 +35,7 @@ post-install:
@ echo "# remove or comment the following line and uncomment the one below it once you have" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
@ echo "# configured your server's data" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
@ echo "echo \"rwhoisd not started; sample data still in place. See ${PREFIX}/share/doc/rwhois for details.\"" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
- @ echo "#[ -x /usr/local/lib/rwhois/sbin/rwhoisd ] && /usr/local/lib/rwhois/sbin/rwhoisd -c /usr/local/lib/rwhois/rwhois.conf & && echo -n ' rwhoisd'" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
+ @ echo "#[ -x ${PREFIX}/lib/rwhois/sbin/rwhoisd ] && ${PREFIX}/lib/rwhois/sbin/rwhoisd -c ${PREFIX}/lib/rwhois/rwhois.conf & && echo -n ' rwhoisd'" >> ${PREFIX}/etc/rc.d/rwhoisd.sh
chmod 751 ${PREFIX}/etc/rc.d/rwhoisd.sh
.include <bsd.port.mk>