aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba-tng/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-05-15 06:51:08 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-05-15 06:51:08 +0800
commit05e660f5f071eaf269ce2998acdcca947e835735 (patch)
tree25a1094a747415fe59d86abf9fa37c52f334f5b6 /net/samba-tng/Makefile
parent74df25c1f236269a7202e3d7150660e99d234ae8 (diff)
downloadfreebsd-ports-gnome-05e660f5f071eaf269ce2998acdcca947e835735.tar.gz
freebsd-ports-gnome-05e660f5f071eaf269ce2998acdcca947e835735.tar.zst
freebsd-ports-gnome-05e660f5f071eaf269ce2998acdcca947e835735.zip
Update to latest cvs version which allows removal of local patches
Take out perl RE for startup script as it isn't required. Use AUTOCONF because it now searches for passwd Add LDAP and CUPS support Fix description in pkg-descr
Diffstat (limited to 'net/samba-tng/Makefile')
-rw-r--r--net/samba-tng/Makefile27
1 files changed, 22 insertions, 5 deletions
diff --git a/net/samba-tng/Makefile b/net/samba-tng/Makefile
index dad59b26662f..26414c7e3688 100644
--- a/net/samba-tng/Makefile
+++ b/net/samba-tng/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: samba
+# New ports collection makefile for: samba-tng
# Date created: 11th May 2002
# Whom: dwcjr
#
@@ -6,10 +6,9 @@
#
PORTNAME= samba-tng
-PORTVERSION= 2.6.1c20020507
+PORTVERSION= 2.6.1c20020514
CATEGORIES= net
MASTER_SITES= http://www.samba-tng.org/download/tng/ \
- http://samba.cadcamlab.org/debian/woody/ \
http://something.inethouston.net/~poseiden/
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}_0.${PORTVERSION:S,c,cvs,}
@@ -18,6 +17,8 @@ MAINTAINER= dwcjr@FreeBSD.org
GNU_CONFIGURE= YES
INSTALLS_SHLIB= YES
USE_GMAKE= YES
+USE_BZIP2= YES
+USE_AUTOCONF= YES
WRKSRC= ${WRKDIR}/tng-clean/source
# directories
@@ -29,7 +30,7 @@ SAMBA_CONFDIR= ${PREFIX}/etc
CONFIGURE_ARGS= --localstatedir=${VARDIR}/lock \
--with-privatedir=${SAMBA_PRIVATE} --with-pam \
- --with-logdir=${VARDIR}/log --with-tmpdir=${VARDIR}/run
+ --with-logdir=${VARDIR}/log --with-tmpdir=${VARDIR}/run/samba-tng
MAN1= debug2html.1 make_smbcodepage.1 nmblookup.1 \
regedit.1 rpcclient.1 smbclient.1 smbrun.1 \
@@ -56,8 +57,24 @@ CONFIGURE_ARGS+= --with-syslog
CONFIGURE_ARGS+= --with-msdfs
.endif
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+CONFIGURE_ARGS+= --with-ldapsam
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+.endif
+
+.if !defined(WITHOUT_CUPS)
+WITH_CUPS= yes
+.endif
+
+.if defined(WITH_CUPS)
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/script/samba-init.d ${SAMBA_CONFDIR}/rc.d/samba-tng.sh.sample
- @${PERL} -pi.fbsd -e 's|tmpdir=/tmp|tmpdir=/var/run/samba-tng|g' ${SAMBA_CONFDIR}/rc.d/samba-tng.sh.sample
.include <bsd.port.post.mk>