aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba-tng
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-05-15 06:51:08 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-05-15 06:51:08 +0800
commit05e660f5f071eaf269ce2998acdcca947e835735 (patch)
tree25a1094a747415fe59d86abf9fa37c52f334f5b6 /net/samba-tng
parent74df25c1f236269a7202e3d7150660e99d234ae8 (diff)
downloadfreebsd-ports-gnome-05e660f5f071eaf269ce2998acdcca947e835735.tar.gz
freebsd-ports-gnome-05e660f5f071eaf269ce2998acdcca947e835735.tar.zst
freebsd-ports-gnome-05e660f5f071eaf269ce2998acdcca947e835735.zip
Update to latest cvs version which allows removal of local patches
Take out perl RE for startup script as it isn't required. Use AUTOCONF because it now searches for passwd Add LDAP and CUPS support Fix description in pkg-descr
Diffstat (limited to 'net/samba-tng')
-rw-r--r--net/samba-tng/Makefile27
-rw-r--r--net/samba-tng/distinfo2
-rw-r--r--net/samba-tng/files/patch-aa24
-rw-r--r--net/samba-tng/pkg-descr2
4 files changed, 23 insertions, 32 deletions
diff --git a/net/samba-tng/Makefile b/net/samba-tng/Makefile
index dad59b26662f..26414c7e3688 100644
--- a/net/samba-tng/Makefile
+++ b/net/samba-tng/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: samba
+# New ports collection makefile for: samba-tng
# Date created: 11th May 2002
# Whom: dwcjr
#
@@ -6,10 +6,9 @@
#
PORTNAME= samba-tng
-PORTVERSION= 2.6.1c20020507
+PORTVERSION= 2.6.1c20020514
CATEGORIES= net
MASTER_SITES= http://www.samba-tng.org/download/tng/ \
- http://samba.cadcamlab.org/debian/woody/ \
http://something.inethouston.net/~poseiden/
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}_0.${PORTVERSION:S,c,cvs,}
@@ -18,6 +17,8 @@ MAINTAINER= dwcjr@FreeBSD.org
GNU_CONFIGURE= YES
INSTALLS_SHLIB= YES
USE_GMAKE= YES
+USE_BZIP2= YES
+USE_AUTOCONF= YES
WRKSRC= ${WRKDIR}/tng-clean/source
# directories
@@ -29,7 +30,7 @@ SAMBA_CONFDIR= ${PREFIX}/etc
CONFIGURE_ARGS= --localstatedir=${VARDIR}/lock \
--with-privatedir=${SAMBA_PRIVATE} --with-pam \
- --with-logdir=${VARDIR}/log --with-tmpdir=${VARDIR}/run
+ --with-logdir=${VARDIR}/log --with-tmpdir=${VARDIR}/run/samba-tng
MAN1= debug2html.1 make_smbcodepage.1 nmblookup.1 \
regedit.1 rpcclient.1 smbclient.1 smbrun.1 \
@@ -56,8 +57,24 @@ CONFIGURE_ARGS+= --with-syslog
CONFIGURE_ARGS+= --with-msdfs
.endif
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+CONFIGURE_ARGS+= --with-ldapsam
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+.endif
+
+.if !defined(WITHOUT_CUPS)
+WITH_CUPS= yes
+.endif
+
+.if defined(WITH_CUPS)
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/script/samba-init.d ${SAMBA_CONFDIR}/rc.d/samba-tng.sh.sample
- @${PERL} -pi.fbsd -e 's|tmpdir=/tmp|tmpdir=/var/run/samba-tng|g' ${SAMBA_CONFDIR}/rc.d/samba-tng.sh.sample
.include <bsd.port.post.mk>
diff --git a/net/samba-tng/distinfo b/net/samba-tng/distinfo
index 1f279c71f1ca..b346e34874e3 100644
--- a/net/samba-tng/distinfo
+++ b/net/samba-tng/distinfo
@@ -1 +1 @@
-MD5 (samba-tng_0.2.6.1cvs20020507.tar.gz) = ee0f2f020d2087e937a8e8fb0d6aa464
+MD5 (samba-tng_0.2.6.1cvs20020514.tar.bz2) = 1b02926b9af8e749357090f9db056555
diff --git a/net/samba-tng/files/patch-aa b/net/samba-tng/files/patch-aa
deleted file mode 100644
index 5e464fbdb59e..000000000000
--- a/net/samba-tng/files/patch-aa
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: Makefile.in
-===================================================================
-RCS file: /home/cvsroot/dcerpc/tng/source/Makefile.in,v
-retrieving revision 1.67
-diff -u -p -r1.67 Makefile.in
---- Makefile.in 7 May 2002 22:18:50 -0000 1.67
-+++ Makefile.in 14 May 2002 15:58:10 -0000
-@@ -43,6 +43,7 @@ RUNTESTDEFAULTFLAGS = --srcdir @srcdir@/
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
- INSTALL_DATA = @INSTALL_DATA@
-+INSTALL_SCRIPT = @INSTALL_SCRIPT@
-
- VPATH=@srcdir@
- srcdir=@srcdir@
-@@ -1189,7 +1190,7 @@ installscripts: installdirs
- @set -e; for f in $(SCRIPTS); do \
- basename=`echo $$f | sed 's,.*/,,'`; \
- echo Installing $(BINDIR)/$$basename; \
-- $(INSTALL_PROGRAM) $$f $(DESTDIR)$(BINDIR)/$$basename; \
-+ $(INSTALL_SCRIPT) $$f $(DESTDIR)$(BINDIR)/$$basename; \
- done
-
- installcp: installdirs $(BUILDBINDIR)/make_smbcodepage $(BUILDBINDIR)/make_unicodemap
diff --git a/net/samba-tng/pkg-descr b/net/samba-tng/pkg-descr
index f1bd2107c1a6..99183a3d7820 100644
--- a/net/samba-tng/pkg-descr
+++ b/net/samba-tng/pkg-descr
@@ -4,7 +4,5 @@ domain controller. Like Samba, Samba-TNG can also act as a file and
print server for LanManager clients such as MS-DOS, OS/2, MS-Windows,
Windows NT and Windows 2000, and as a WINS (Windows Internet Name
Service) server.
-.
-This is needed by both the client and server portions of Samba-TNG.
WWW: http://www.samba-tng.org/