aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-03-14 02:49:52 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-03-14 02:49:52 +0800
commit5d9ebe90b268bb6565b8d324b931596971c16526 (patch)
treeca634fd5f2639cc1c727e62aaa47146c70f9163e /net/samba/Makefile
parent39d987a612fffa2f60e0b9c1b423dca85a87debf (diff)
downloadfreebsd-ports-gnome-5d9ebe90b268bb6565b8d324b931596971c16526.tar.gz
freebsd-ports-gnome-5d9ebe90b268bb6565b8d324b931596971c16526.tar.zst
freebsd-ports-gnome-5d9ebe90b268bb6565b8d324b931596971c16526.zip
Fix ldap support
Add SSL support Add Syslog support Submitted by: U.Drolshagen@t-online.de, rehsack@liwing.de, rolnas@takas.lt
Diffstat (limited to 'net/samba/Makefile')
-rw-r--r--net/samba/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net/samba/Makefile b/net/samba/Makefile
index afbc508c3b15..b6991ca93f33 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -41,6 +41,14 @@ CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
.include <bsd.port.pre.mk>
+.if defined(WITH_SYSLOG)
+CONFIGURE_ARGS+= --with-syslog
+.endif
+
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+= --with-ssl -ssl-inc=/usr/include/openssl --ssl-lib=/usr/lib
+.endif
+
.if defined(WITH_LDAP)
LIB_DEPENDS+= ldap.2:\${PORTSDIR}/net/openldap2
CONFIGURE_ARGS+=--with-ldapsam