aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba3/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-30 03:11:28 +0800
committerpav <pav@FreeBSD.org>2004-03-30 03:11:28 +0800
commit0126fc857c82fcddf6556b74bbbeb0a269e6adda (patch)
tree36d5360e9d6a1a68777513211a553887a6f13ce6 /net/samba3/Makefile
parent10081a05dd1abab320eb51fd9b5b4c30c36853a9 (diff)
downloadfreebsd-ports-gnome-0126fc857c82fcddf6556b74bbbeb0a269e6adda.tar.gz
freebsd-ports-gnome-0126fc857c82fcddf6556b74bbbeb0a269e6adda.tar.zst
freebsd-ports-gnome-0126fc857c82fcddf6556b74bbbeb0a269e6adda.zip
- Convert samba-libsmbclient into a slave port of samba-devel.
PR: ports/64523 Submitted by: Timur I. Bakeyev <timur@com.bat.ru> (samba-devel maintainer) Approved by: Koop Mast <kwm@rainbow-runner.nl> (samba-libsmbclient maintainer)
Diffstat (limited to 'net/samba3/Makefile')
-rw-r--r--net/samba3/Makefile76
1 files changed, 43 insertions, 33 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 4cd747650fa2..51072b300654 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -7,42 +7,19 @@
PORTNAME= samba
PORTVERSION= 3.0.2.a
-PORTREVISION= 1
-PORTEPOCH= 1
-CATEGORIES= net
+PORTREVISION?= 1
+PORTEPOCH?= 1
+CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
MASTER_SITE_SUBDIR= . rc
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/:S/.a/a/}
-MAINTAINER= timur@gnu.org
-COMMENT= A free SMB and CIFS client and server for UNIX
+MAINTAINER?= timur@gnu.org
+COMMENT?= A free SMB and CIFS client and server for UNIX
-CONFLICTS= ja-samba-2.* samba-2.* sharity-light-1.* samba-libsmbclient-3.*
-
-OPTIONS= CUPS "With CUPS printing support" on \
- LDAP "With LDAP support" on \
- ADS "With Active Directory support" on \
- WINBIND "With WinBIND support" on \
- ACL_SUPPORT "With ACL support" off \
- SYSLOG "With Syslog support" off \
- QUOTAS "With Quota support" off \
- UTMP "With UTMP support" on \
- MSDFS "With MSDFS support" off \
- SAM_XML "With XML smbpasswd backend" off \
- SAM_MYSQL "With MYSQL smbpasswd backend" off \
- SAM_PGSQL "With PostgreSQL smbpasswd backend" off \
- SAM_OLD_LDAP "With Samba2.x LDAP smbpasswd backend" off \
- PAM_SMBPASS "With SMB PAM module" off \
- PYTHON "With Python experimental bindings" off \
- LIBICONV "With installed ICONV library" off \
- POPT "With installed POPT library" on
+CONFLICTS?= ja-samba-2.* samba-2.* sharity-light-1.* samba-libsmbclient-3.*
USE_BZIP2= yes
-USE_RC_SUBR= yes
-NO_LATEST_LINK= yes
-INSTALLS_SHLIB= yes
-USE_AUTOCONF_VER= 253
-
# directories
VARDIR= ${DESTDIR}/var
SAMBA_SPOOL?= ${VARDIR}/spool/samba
@@ -59,7 +36,8 @@ SAMBA_CONFIG= ${SAMBA_CONFDIR}/smb.conf
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
-CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
+
+CONFIGURE_ARGS+=--exec-prefix=${PREFIX} \
--libdir=${SAMBA_LIBDIR}/samba \
--localstatedir=${VARDIR} \
--with-configdir=${SAMBA_CONFDIR} \
@@ -68,11 +46,43 @@ CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
--with-lockdir=${SAMBA_SPOOL} --with-piddir=${SAMBA_RUNDIR} \
--with-privatedir=${SAMBA_PRIVATE} \
--with-logfilebase=${SAMBA_LOGDIR} \
- --with-pam --with-readline --with-libsmbclient \
--with-manpages-langs=en
+WRKSRC= ${WRKDIR}/${DISTNAME}/source
+
+# SUBPORTS end here
+.if defined(SAMBA_SUBPORT)
+.include <bsd.port.mk>
+.else
+
+NO_LATEST_LINK= yes
+INSTALLS_SHLIB= yes
+USE_RC_SUBR= yes
+USE_AUTOCONF_VER= 253
+
+OPTIONS= CUPS "With CUPS printing support" on \
+ LDAP "With LDAP support" on \
+ ADS "With Active Directory support" on \
+ WINBIND "With WinBIND support" on \
+ ACL_SUPPORT "With ACL support" off \
+ SYSLOG "With Syslog support" off \
+ QUOTAS "With Quota support" off \
+ UTMP "With UTMP support" on \
+ MSDFS "With MSDFS support" off \
+ SAM_XML "With XML smbpasswd backend" off \
+ SAM_MYSQL "With MYSQL smbpasswd backend" off \
+ SAM_PGSQL "With PostgreSQL smbpasswd backend" off \
+ SAM_OLD_LDAP "With Samba2.x LDAP smbpasswd backend" off \
+ PAM_SMBPASS "With SMB PAM module" off \
+ PYTHON "With Python experimental bindings" off \
+ LIBICONV "With installed ICONV library" off \
+ POPT "With installed POPT library" on
+
.include <bsd.port.pre.mk>
+CONFIGURE_ARGS+= --with-pam --with-readline \
+ --with-libsmbclient
+
.if defined(WITH_PYTHON)
USE_PYTHON= 2.1+
# Hack to make it work with OPTIONS. Breaks portlint
@@ -233,8 +243,6 @@ LIB_DEPENDS+= popt.0:${PORTSDIR}/devel/popt
CONFIGURE_ARGS+= --with-included-popt
.endif
-WRKSRC= ${WRKDIR}/${DISTNAME}/source
-
MLINKS= samba.7 Samba.7
MAN1= findsmb.1 nmblookup.1 log2pcap.1 rpcclient.1 \
smbget.1 smbcacls.1 smbclient.1 smbcontrol.1 smbsh.1 \
@@ -356,3 +364,5 @@ post-install:
.endif
.include <bsd.port.post.mk>
+
+.endif