aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba3
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-05-12 03:23:16 +0800
committermarcus <marcus@FreeBSD.org>2004-05-12 03:23:16 +0800
commitc5812546c26de2ffd4ecd24adb03490ab11aeca9 (patch)
treec691f7d3075c5d86837e4f78211480880371a5a4 /net/samba3
parent2a92c8427e7312a24da76b807289901735d04405 (diff)
downloadfreebsd-ports-gnome-c5812546c26de2ffd4ecd24adb03490ab11aeca9.tar.gz
freebsd-ports-gnome-c5812546c26de2ffd4ecd24adb03490ab11aeca9.tar.zst
freebsd-ports-gnome-c5812546c26de2ffd4ecd24adb03490ab11aeca9.zip
Fix the kerberos dependency so that this will properly build on the clusters,
and retain its kerberos dependency at runtime. Submitted by: maintainer
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 5a2bbb5e8ea8..865cac003f8a 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -214,13 +214,8 @@ CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME}
.elif ( defined(MAKE_KERBEROS5) || ${OSVERSION} > 500105 ) && exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr
.else
-BUILD_DEPENDS+= krb5-config:${PORTSDIR}/security/heimdal
-KRB5_PREFIX!= krb5-config --prefix 2>/dev/null || true
-.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
-CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
-.else
-BROKEN= "Kerberos5 is necessary for ADS support. Please, install either Heimdal or MIT-Kerberos"
-.endif
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE}
.endif
.else
CONFIGURE_ARGS+= --without-krb5