aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba3
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-01-10 19:12:50 +0800
committeredwin <edwin@FreeBSD.org>2004-01-10 19:12:50 +0800
commitb246c49c02f4dfa24129c940ea976bd03beceb88 (patch)
tree2280d55d3b39dbaaa9cfeb3adefb8a5ac0934e91 /net/samba3
parentbf02049e70dd98b1681d757bf1763a51ac2720b1 (diff)
downloadfreebsd-ports-gnome-b246c49c02f4dfa24129c940ea976bd03beceb88.tar.gz
freebsd-ports-gnome-b246c49c02f4dfa24129c940ea976bd03beceb88.tar.zst
freebsd-ports-gnome-b246c49c02f4dfa24129c940ea976bd03beceb88.zip
[PATCH] Fix library dependencies in samba-devel port
The net/samba-devel port has a WITHOUT_CUPS Makefile option that drops the *port's* dependency on the CUPS library, but does not actually pass the option to configure to build Samba without CUPS support. The resulting binaries will still have a runtime dependency on the CUPS library. Similarly, the binaries built by the port have a runtime dependency on the popt (port devel/popt) library which is not listed in the Makefile. PR: ports/53939 Submitted by: Scott Mitchell <scott+freebsd@fishballoon.org> Approved by: maintainer timeout
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 5c542d733936..7a631dd77654 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= samba
PORTVERSION= 3.0.0
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://us3.samba.org/samba/ftp/%SUBDIR%/
MASTER_SITE_SUBDIR= . rc
@@ -18,10 +19,12 @@ COMMENT= A free SMB and CIFS client and server for UNIX
CONFLICTS= ja-samba-2.* samba-3.* samba-libsmbclient-3.* sharity-light-1.*
-USE_BZIP2="YES"
+USE_BZIP2= yes
.if !defined(WITHOUT_CUPS)
WITH_CUPS= yes
+.else
+CONFIGURE_ARGS+= --enable-cups=no
.endif
.if defined(WITH_CUPS)
@@ -92,6 +95,12 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
CONFIGURE_ARGS+= --with-libiconv
.endif
+.if defined(WITHOUT_POPT)
+CONFIGURE_ARGS+= --with-included-popt
+.else
+LIB_DEPENDS+= popt.0:${PORTSDIR}/devel/popt
+.endif
+
WRKSRC= ${WRKDIR}/${DISTNAME}/source
MAN1= findsmb.1 nmblookup.1 log2pcap.1 \