aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba4wins/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-09-01 02:04:20 +0800
committerpav <pav@FreeBSD.org>2006-09-01 02:04:20 +0800
commitb0b5ac7d0467c17777a53d7284494837e23ecbc6 (patch)
tree36db2f5ba16736422cee893876da96ebf3b2e91d /net/samba4wins/Makefile
parentf33bdf1524640761dd97d4cbfd10b272024a77f3 (diff)
downloadfreebsd-ports-gnome-b0b5ac7d0467c17777a53d7284494837e23ecbc6.tar.gz
freebsd-ports-gnome-b0b5ac7d0467c17777a53d7284494837e23ecbc6.tar.zst
freebsd-ports-gnome-b0b5ac7d0467c17777a53d7284494837e23ecbc6.zip
- Update to 1.0.4.r1
PR: ports/102713 Submitted by: Timur I. Bakeyev <timur@gnu.org> (maintainer)
Diffstat (limited to 'net/samba4wins/Makefile')
-rw-r--r--net/samba4wins/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
index b374413f2b4c..61191a93ca72 100644
--- a/net/samba4wins/Makefile
+++ b/net/samba4wins/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= samba4wins
-PORTVERSION= 1.0.3.r1
+PORTVERSION= 1.0.4.r1
CATEGORIES= net
MASTER_SITES= http://ftp.sernet.de/pub/samba4WINS/debian/pool/
DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/-/}
@@ -16,13 +16,15 @@ COMMENT= A full featured replicating WINS server for UNIX
CONFLICTS= ja-samba-2.* ja-samba-4.* samba-2.* samba-4.* sharity-light-1.*
+USE_ICONV= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:259 autoheader:259
WRKSRC= ${WRKDIR}/${PORTNAME}/source
# directories
-VARDIR= ${DESTDIR}/var
+VARDIR?= ${DESTDIR}/var
S4W_DATADIR= ${PREFIX}/share/${PORTNAME}
S4W_LOGDIR= ${VARDIR}/log/${PORTNAME}
S4W_RUNDIR= ${VARDIR}/run
@@ -48,12 +50,18 @@ CONFIGURE_ARGS+= --disable-reg-gconf --disable-socket-wrapper \
--with-libiconv=${LOCALBASE} --without-sqlite3 \
--without-pthreads --without-python
-USE_RC_SUBR= smbd4wins.sh
+USE_RC_SUBR= smbd4wins
SUB_LIST+= S4W_RUNDIR=${S4W_RUNDIR}
PLIST_SUB+= S4W_LOGDIR=${S4W_LOGDIR} \
S4W_LOCKDIR=${S4W_LOCKDIR}
+post-build:
+ @for f in ${WRKSRC}/scripting/bin/*; do \
+ ${REINPLACE_CMD} -i '' -e 's|smbscript|${PREFIX}/bin/smbscript4|' \
+ $${f} && ${MV} $${f} $${f}4; \
+ done
+
post-install:
@${MKDIR} ${S4W_CONFDIR}
${INSTALL_DATA} ${FILESDIR}/samba4wins.conf.sample ${S4W_CONFDIR}