aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba4wins
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-04-18 21:05:06 +0800
committersem <sem@FreeBSD.org>2006-04-18 21:05:06 +0800
commitd0f784e795641a47a49fe0fe6a382eb4665f8fd4 (patch)
treec7f5b76dffb112a7028165585d864b51b9ec0264 /net/samba4wins
parent69a2cf2a67498e1d14649da4c1f8c02ee85e4f26 (diff)
downloadfreebsd-ports-gnome-d0f784e795641a47a49fe0fe6a382eb4665f8fd4.tar.gz
freebsd-ports-gnome-d0f784e795641a47a49fe0fe6a382eb4665f8fd4.tar.zst
freebsd-ports-gnome-d0f784e795641a47a49fe0fe6a382eb4665f8fd4.zip
The Samba4WINS project provides a full featured replicating WINS server
for UNIX. It is a spinoff of the Samba 4 project, the upcoming version of the Samba software suite and will also be available as part of the Samba suite as soon as Samba 4 is released. WWW: http://enterprisesamba.org/index.php?id=88 PR: ports/95774 Submitted by: Timur I. Bakeyev <timur@gnu.org>
Diffstat (limited to 'net/samba4wins')
-rw-r--r--net/samba4wins/Makefile67
-rw-r--r--net/samba4wins/distinfo3
-rw-r--r--net/samba4wins/files/patch-main.mk12
-rw-r--r--net/samba4wins/files/patch-utils_config.mk11
-rw-r--r--net/samba4wins/files/samba4wins.conf.sample29
-rw-r--r--net/samba4wins/files/smbd4wins.sh.in25
-rw-r--r--net/samba4wins/pkg-descr6
-rw-r--r--net/samba4wins/pkg-plist51
8 files changed, 204 insertions, 0 deletions
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
new file mode 100644
index 000000000000..b374413f2b4c
--- /dev/null
+++ b/net/samba4wins/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: samba4wins
+# Date created: 11th Apr 2006
+# Whom: Timur I. Bakeyev <timur@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= samba4wins
+PORTVERSION= 1.0.3.r1
+CATEGORIES= net
+MASTER_SITES= http://ftp.sernet.de/pub/samba4WINS/debian/pool/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/-/}
+
+MAINTAINER= timur@gnu.org
+COMMENT= A full featured replicating WINS server for UNIX
+
+CONFLICTS= ja-samba-2.* ja-samba-4.* samba-2.* samba-4.* sharity-light-1.*
+
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/source
+
+# directories
+VARDIR= ${DESTDIR}/var
+S4W_DATADIR= ${PREFIX}/share/${PORTNAME}
+S4W_LOGDIR= ${VARDIR}/log/${PORTNAME}
+S4W_RUNDIR= ${VARDIR}/run
+S4W_LOCKDIR= ${VARDIR}/db/${PORTNAME}
+S4W_PRIVATE= ${S4W_LOCKDIR}/private
+S4W_CONFDIR= ${PREFIX}/etc
+S4W_LIBDIR= ${PREFIX}/lib/${PORTNAME}
+S4W_CONFIG= ${S4W_CONFDIR}/samba4wins.conf
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
+ --datadir=${S4W_DATADIR} \
+ --libdir=${S4W_LIBDIR} \
+ --localstatedir=${VARDIR} \
+ --with-privatedir=${S4W_PRIVATE} \
+ --with-lockdir=${S4W_LOCKDIR} \
+ --with-piddir=${S4W_RUNDIR} \
+ --with-logfilebase=${S4W_LOGDIR}
+
+CONFIGURE_ARGS+= --disable-reg-gconf --disable-socket-wrapper \
+ --with-readline=/usr --with-included-popt \
+ --with-libiconv=${LOCALBASE} --without-sqlite3 \
+ --without-pthreads --without-python
+
+USE_RC_SUBR= smbd4wins.sh
+SUB_LIST+= S4W_RUNDIR=${S4W_RUNDIR}
+
+PLIST_SUB+= S4W_LOGDIR=${S4W_LOGDIR} \
+ S4W_LOCKDIR=${S4W_LOCKDIR}
+
+post-install:
+ @${MKDIR} ${S4W_CONFDIR}
+ ${INSTALL_DATA} ${FILESDIR}/samba4wins.conf.sample ${S4W_CONFDIR}
+ @${MKDIR} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+.for d in HOWTO.txt NEWS.txt README.txt TODO.txt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/debian/${PORTNAME}-*-${d} ${DOCSDIR}/${d}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/samba4wins/distinfo b/net/samba4wins/distinfo
new file mode 100644
index 000000000000..73a86d17a34c
--- /dev/null
+++ b/net/samba4wins/distinfo
@@ -0,0 +1,3 @@
+MD5 (samba4wins_1.0.3-1.tar.gz) = 97d3de004859230c7550ed8858d356ea
+SHA256 (samba4wins_1.0.3-1.tar.gz) = 8613e61093d078de3b1c19de1bc242ded4f6a0502e4b44c5ef9077f1028a9c54
+SIZE (samba4wins_1.0.3-1.tar.gz) = 18788362
diff --git a/net/samba4wins/files/patch-main.mk b/net/samba4wins/files/patch-main.mk
new file mode 100644
index 000000000000..af8793ebeb3a
--- /dev/null
+++ b/net/samba4wins/files/patch-main.mk
@@ -0,0 +1,12 @@
+--- main.mk.orig Sun Apr 9 04:52:10 2006
++++ main.mk Sun Apr 9 04:52:33 2006
+@@ -86,8 +86,7 @@
+ -DMODULESDIR=\"$(MODULESDIR)\" -DJSDIR=\"$(JSDIR)\" \
+ -DSETUPDIR=\"$(SETUPDIR)\"
+
+-install: showlayout installbin installdat installswat installmisc installlib \
+- installheader installpc
++install: showlayout installbin installdat installmisc installlib installpc
+
+ # DESTDIR is used here to prevent packagers wasting their time
+ # duplicating the Makefile. Remove it and you will have the privilege
diff --git a/net/samba4wins/files/patch-utils_config.mk b/net/samba4wins/files/patch-utils_config.mk
new file mode 100644
index 000000000000..fedc67360658
--- /dev/null
+++ b/net/samba4wins/files/patch-utils_config.mk
@@ -0,0 +1,11 @@
+--- utils/config.mk.orig Sun Apr 9 23:55:42 2006
++++ utils/config.mk Sun Apr 9 23:56:16 2006
+@@ -77,7 +77,7 @@
+
+ #################################
+ # Start BINARY nmblookup
+-[BINARY::nmblookup]
++[BINARY::nmblookup4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES = \
+ nmblookup.o
diff --git a/net/samba4wins/files/samba4wins.conf.sample b/net/samba4wins/files/samba4wins.conf.sample
new file mode 100644
index 000000000000..d4f52eae6fb1
--- /dev/null
+++ b/net/samba4wins/files/samba4wins.conf.sample
@@ -0,0 +1,29 @@
+#
+# /usr/local/etc/samba4wins.conf
+#
+# Please read the following files carefully!
+#
+# /usr/local/share/doc/samba4wins/:
+# README.txt
+# NEWS.txt
+# HOWTO.txt
+# TODO.txt
+#
+
+[globals]
+ # it's important that this netbios name is different from
+ # the one that's used for samba3!
+ ###netbios name = SERVER1-WINS
+ # only use the given interfaces
+ ###bind interfaces only = yes
+ # this is the unicast address
+ ###interfaces = 192.168.9.2
+ # samba4wins is only a wins server,
+ # and broadcasts are handled by samba3
+ # so disable listening on the broadcast address
+ ###nbtd:disable_broadcast = yes
+
+ # as we want to ourself as wins server
+ # and don't listen on 127.0.0.1
+ # we need to explicit set the wins server here
+ ###wins server = 192.168.9.2
diff --git a/net/samba4wins/files/smbd4wins.sh.in b/net/samba4wins/files/smbd4wins.sh.in
new file mode 100644
index 000000000000..095b756f7eb6
--- /dev/null
+++ b/net/samba4wins/files/smbd4wins.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: smbd2wins
+# REQUIRE: NETWORKING SERVERS named ldconfig
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable smbd:
+#
+#smbd4wins_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name="smbd4wins"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/sbin/${name}"
+pidfile="%%S4W_RUNDIR%%/${name}.pid"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/samba4wins/pkg-descr b/net/samba4wins/pkg-descr
new file mode 100644
index 000000000000..2db57a1565f6
--- /dev/null
+++ b/net/samba4wins/pkg-descr
@@ -0,0 +1,6 @@
+The Samba4WINS project provides a full featured replicating WINS server
+for UNIX. It is a spinoff of the Samba 4 project, the upcoming version
+of the Samba software suite and will also be available as part of the
+Samba suite as soon as Samba 4 is released.
+
+WWW: http://enterprisesamba.org/index.php?id=88
diff --git a/net/samba4wins/pkg-plist b/net/samba4wins/pkg-plist
new file mode 100644
index 000000000000..8c87451aa3b0
--- /dev/null
+++ b/net/samba4wins/pkg-plist
@@ -0,0 +1,51 @@
+@unexec %D/etc/rc.d/samba4wins.sh forcestop 2>/dev/null || true
+etc/samba4wins.conf.sample
+bin/nmblookup4
+bin/ldbadd
+bin/ldbdel
+bin/ldbedit
+bin/ldbmodify
+bin/ldbrename
+bin/ldbsearch
+bin/samba3dump
+bin/smbscript
+bin/smbstatus
+bin/smbtorture
+bin/testparm
+bin/winreg
+sbin/smbd4wins
+lib/samba4wins/lowcase.dat
+lib/samba4wins/upcase.dat
+lib/samba4wins/valid.dat
+%%PORTDOCS%%%%DOCSDIR%%/HOWTO.txt
+%%PORTDOCS%%%%DOCSDIR%%/NEWS.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
+%%DATADIR%%/js/auth.js
+%%DATADIR%%/js/base.js
+%%DATADIR%%/js/encoder.js
+%%DATADIR%%/js/management.js
+%%DATADIR%%/js/provision.js
+%%DATADIR%%/js/samr.js
+%%DATADIR%%/js/server_call.js
+%%DATADIR%%/js/upgrade.js
+%%DATADIR%%/js/winreg.js
+%%DATADIR%%/setup/display_specifiers.ldif
+%%DATADIR%%/setup/hklm.ldif
+%%DATADIR%%/setup/provision.ldif
+%%DATADIR%%/setup/provision.smb.conf
+%%DATADIR%%/setup/provision.zone
+%%DATADIR%%/setup/provision_init.ldif
+%%DATADIR%%/setup/provision_templates.ldif
+%%DATADIR%%/setup/provision_users.ldif
+%%DATADIR%%/setup/schema.ldif
+%%DATADIR%%/setup/secrets.ldif
+@dirrmtry lib/samba4wins/pkgconfig
+@dirrmtry private/tls
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/setup
+@dirrm %%DATADIR%%/js
+@dirrm %%DATADIR%%
+@dirrm lib/samba4wins
+@unexec echo "Warning: If you will *NOT* use this package anymore, please remove %%S4W_LOCKDIR%%/* manually."
+@unexec echo "Warning: If you will *NOT* use this package anymore, please remove %%S4W_LOGDIR%%/* manually."