aboutsummaryrefslogtreecommitdiffstats
path: root/net/scnc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-20 16:00:03 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-20 16:00:03 +0800
commitc897562bca636e63b9b43c2a713cae9dbd8d923f (patch)
tree835a3ceb91c3601f1436a22c72f3fe958de223b7 /net/scnc
parenteac84e685080011fb29ef96b7c0abc1243efe80b (diff)
downloadfreebsd-ports-gnome-c897562bca636e63b9b43c2a713cae9dbd8d923f.tar.gz
freebsd-ports-gnome-c897562bca636e63b9b43c2a713cae9dbd8d923f.tar.zst
freebsd-ports-gnome-c897562bca636e63b9b43c2a713cae9dbd8d923f.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'net/scnc')
-rw-r--r--net/scnc/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net/scnc/Makefile b/net/scnc/Makefile
index 5e99fb840913..b086df6391cc 100644
--- a/net/scnc/Makefile
+++ b/net/scnc/Makefile
@@ -15,11 +15,13 @@ RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PLIST_FILES= bin/${PORTNAME}
+USES= shebangfix
NO_BUILD= yes
-NO_STAGE= yes
+PLIST_FILES= bin/scnc
+SHEBANG_FILES= scnc
+
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>