aboutsummaryrefslogtreecommitdiffstats
path: root/net/ser
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2005-03-15 16:54:51 +0800
committersobomax <sobomax@FreeBSD.org>2005-03-15 16:54:51 +0800
commitb712324f2ca4eb2ebaed2b0e92222ec7b6dfba84 (patch)
tree5efacb636663f8861447830ddeb4459589ff2d7f /net/ser
parent60e8685ff51802f95b1751e54d4a0e6b0e0e9718 (diff)
downloadfreebsd-ports-gnome-b712324f2ca4eb2ebaed2b0e92222ec7b6dfba84.tar.gz
freebsd-ports-gnome-b712324f2ca4eb2ebaed2b0e92222ec7b6dfba84.tar.zst
freebsd-ports-gnome-b712324f2ca4eb2ebaed2b0e92222ec7b6dfba84.zip
Fix possible coredump in usrloc module (backported from soon to be released
0.9.0. Reported by: Barry Murphy <barry@unix.co.nz>
Diffstat (limited to 'net/ser')
-rw-r--r--net/ser/Makefile1
-rw-r--r--net/ser/files/patch-modules::usrloc::udomain.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/net/ser/Makefile b/net/ser/Makefile
index b2f3c863ec5f..05bc382dfadd 100644
--- a/net/ser/Makefile
+++ b/net/ser/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ser
PORTVERSION= 0.8.14
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.berlios.de/pub/ser/${PORTVERSION}/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
diff --git a/net/ser/files/patch-modules::usrloc::udomain.c b/net/ser/files/patch-modules::usrloc::udomain.c
new file mode 100644
index 000000000000..3e627f8ef7eb
--- /dev/null
+++ b/net/ser/files/patch-modules::usrloc::udomain.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- modules/usrloc/udomain.c
++++ modules/usrloc/udomain.c
+@@ -288,7 +288,7 @@
+ }
+ flags = VAL_BITMAP(ROW_VALUES(row) + 8);
+ ua.s = (char*)VAL_STRING(ROW_VALUES(row) + 9);
+- ua.len = strlen(ua.s);
++ ua.len = (ua.s != NULL) ? strlen(ua.s) : 0;
+
+ if (use_domain) {
+ domain = (char*)VAL_STRING(ROW_VALUES(row) + 10);