aboutsummaryrefslogtreecommitdiffstats
path: root/net/serveez
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-19 00:03:16 +0800
committerpetef <petef@FreeBSD.org>2003-05-19 00:03:16 +0800
commit54b4063cec319dac240785ffe33fcd1f5b6ca137 (patch)
tree8f9ac94e89713c171cc8e976c28e5ff81427f733 /net/serveez
parent0fedbb493ef2525e061daf8022932e02fafe1aa0 (diff)
downloadfreebsd-ports-gnome-54b4063cec319dac240785ffe33fcd1f5b6ca137.tar.gz
freebsd-ports-gnome-54b4063cec319dac240785ffe33fcd1f5b6ca137.tar.zst
freebsd-ports-gnome-54b4063cec319dac240785ffe33fcd1f5b6ca137.zip
Use USE_GETOPT_LONG.
PR: 51387, 51383, 51380, 51388, 51384, 51372, 51373, 51381, 51382 Submitted by: Ports Fury
Diffstat (limited to 'net/serveez')
-rw-r--r--net/serveez/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/net/serveez/Makefile b/net/serveez/Makefile
index 2b5f0b048941..a6b0fa65e7d9 100644
--- a/net/serveez/Makefile
+++ b/net/serveez/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
GUILE_CONFIG?= ${LOCALBASE}/bin/guile-config
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
@@ -35,10 +36,4 @@ MAN1= serveez.1
CPPFLAGS= `${GUILE_CONFIG} compile`
LDFLAGS= `${GUILE_CONFIG} link`
-.if !exists(/usr/include/getopt.h)
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
-.endif
-
.include <bsd.port.mk>