aboutsummaryrefslogtreecommitdiffstats
path: root/net/simicq
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-10-15 17:37:55 +0800
committermarkus <markus@FreeBSD.org>2004-10-15 17:37:55 +0800
commit1a236e2037682229bd8ca724891304d823a5ebc2 (patch)
tree6e9021fb5736f89ccf844dd4bf3a4688a638f6ed /net/simicq
parentcfea6cf1c0e892a5c051c568a945aeb084b02b65 (diff)
downloadfreebsd-ports-gnome-1a236e2037682229bd8ca724891304d823a5ebc2.tar.gz
freebsd-ports-gnome-1a236e2037682229bd8ca724891304d823a5ebc2.tar.zst
freebsd-ports-gnome-1a236e2037682229bd8ca724891304d823a5ebc2.zip
Fix build if WITHOUT_SSL and WITHOUT_KDE are specified
Reported by: Eugene Ossintsev <eugos@gmx.net> Peter Seipel <webghost@lego-hc11.de>
Diffstat (limited to 'net/simicq')
-rw-r--r--net/simicq/Makefile5
-rw-r--r--net/simicq/files/patch-sim-api-fetch.cpp11
-rw-r--r--net/simicq/pkg-plist2
3 files changed, 17 insertions, 1 deletions
diff --git a/net/simicq/Makefile b/net/simicq/Makefile
index 7c037f8d10ee..2c98fd705147 100644
--- a/net/simicq/Makefile
+++ b/net/simicq/Makefile
@@ -58,4 +58,9 @@ post-patch:
@${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
${CONFIGURE_WRKSRC}/configure
+post-configure:
+.if defined(WITHOUT_SSL)
+ @${REINPLACE_CMD} -e 's|plugins/yahoo||g' ${WRKSRC}/Makefile
+.endif
+
.include <bsd.port.mk>
diff --git a/net/simicq/files/patch-sim-api-fetch.cpp b/net/simicq/files/patch-sim-api-fetch.cpp
new file mode 100644
index 000000000000..982bc837c1dd
--- /dev/null
+++ b/net/simicq/files/patch-sim-api-fetch.cpp
@@ -0,0 +1,11 @@
+--- sim/api/fetch.cpp.orig Fri Oct 15 01:17:45 2004
++++ sim/api/fetch.cpp Fri Oct 15 01:21:31 2004
+@@ -24,6 +24,8 @@
+ #include <qthread.h>
+ #include <qtimer.h>
+
++#include <time.h>
++
+ typedef map<my_string, string> HEADERS_MAP;
+
+ class FetchThread;
diff --git a/net/simicq/pkg-plist b/net/simicq/pkg-plist
index b10461b9c1e7..122fbcdd7d7e 100644
--- a/net/simicq/pkg-plist
+++ b/net/simicq/pkg-plist
@@ -40,7 +40,7 @@ lib/sim/styles.so
%%KDE%%lib/sim/transparent.so
lib/sim/update.so
lib/sim/weather.so
-lib/sim/yahoo.so
+%%SSL%%lib/sim/yahoo.so
lib/sim/zodiak.so
share/applnk/Internet/sim.desktop
share/apps/sim/COPYING