aboutsummaryrefslogtreecommitdiffstats
path: root/net/skstream
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-10 06:49:07 +0800
committerpav <pav@FreeBSD.org>2005-02-10 06:49:07 +0800
commitb58a0515c150f5dfaa51b2f7be82f8891a20fec9 (patch)
tree957698d787dc4ee0121ea652047623061924096f /net/skstream
parent996f359d6a38d6e7cb2fa1b1d177510610251a90 (diff)
downloadfreebsd-ports-gnome-b58a0515c150f5dfaa51b2f7be82f8891a20fec9.tar.gz
freebsd-ports-gnome-b58a0515c150f5dfaa51b2f7be82f8891a20fec9.tar.zst
freebsd-ports-gnome-b58a0515c150f5dfaa51b2f7be82f8891a20fec9.zip
Skstream is an iostream based C++ socket library.
PR: ports/77047 Submitted by: Jan Rochel <jannisan@t-online.de>
Diffstat (limited to 'net/skstream')
-rw-r--r--net/skstream/Makefile26
-rw-r--r--net/skstream/distinfo2
-rw-r--r--net/skstream/files/patch-Makefile.in19
-rw-r--r--net/skstream/pkg-descr13
-rw-r--r--net/skstream/pkg-plist23
5 files changed, 83 insertions, 0 deletions
diff --git a/net/skstream/Makefile b/net/skstream/Makefile
new file mode 100644
index 000000000000..f9ac4d771f9a
--- /dev/null
+++ b/net/skstream/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: skstream
+# Date created: 3 February 2005
+# Whom: Janni
+#
+# $FreeBSD$
+#
+
+PORTNAME= skstream
+PORTVERSION= 0.3.3
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.worldforge.org/pub/worldforge/libs/skstream/ \
+ http://purple.worldforge.org/downloads/libs/sktream/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= worldforge
+
+MAINTAINER= jannisan@t-online.de
+COMMENT= An iostream based C++ socket library
+
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/skstream/distinfo b/net/skstream/distinfo
new file mode 100644
index 000000000000..2be0118d4747
--- /dev/null
+++ b/net/skstream/distinfo
@@ -0,0 +1,2 @@
+MD5 (skstream-0.3.3.tar.gz) = 4c7b2d6dbe6c9b15c86ac4c45f49bbe2
+SIZE (skstream-0.3.3.tar.gz) = 352379
diff --git a/net/skstream/files/patch-Makefile.in b/net/skstream/files/patch-Makefile.in
new file mode 100644
index 000000000000..381b872062c7
--- /dev/null
+++ b/net/skstream/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+*** Makefile.in.orig Thu Feb 3 10:18:20 2005
+--- Makefile.in Thu Feb 3 10:20:19 2005
+***************
+*** 213,219 ****
+ target_cpu = @target_cpu@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+! pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = skstream-0.3.pc @SKSTREAM_UNIX_PC@
+ @HAVE_PROG_ZIP_FALSE@MSVC_SUPPORT =
+ @HAVE_PROG_ZIP_TRUE@MSVC_SUPPORT = VisualC.zip
+--- 213,219 ----
+ target_cpu = @target_cpu@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+! pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = skstream-0.3.pc @SKSTREAM_UNIX_PC@
+ @HAVE_PROG_ZIP_FALSE@MSVC_SUPPORT =
+ @HAVE_PROG_ZIP_TRUE@MSVC_SUPPORT = VisualC.zip
diff --git a/net/skstream/pkg-descr b/net/skstream/pkg-descr
new file mode 100644
index 000000000000..3d83555197b4
--- /dev/null
+++ b/net/skstream/pkg-descr
@@ -0,0 +1,13 @@
+Skstream is an iostream based C++ socket library. It is ideally suited for use
+as the underlying transport for Atlas-C++, and has been well tested and
+debugged. It was first discovered for WorldForge when it was used in UClient
+and has since been packaged up as its own library for use on other WorldForge
+projects. The code was originally written by Rafael Guterres Jeffman who is
+not involved with the project but we have extensively rewritten it, and added
+new features such as IPv6 support and unix domain sockets. It now maintained
+for WorldForge by Al Riddoch and others.
+
+WWW: http://www.worldforge.org/dev/eng/libraries/skstream/
+
+- Janni
+jannisan@t-online.de
diff --git a/net/skstream/pkg-plist b/net/skstream/pkg-plist
new file mode 100644
index 000000000000..a32a3fb1505a
--- /dev/null
+++ b/net/skstream/pkg-plist
@@ -0,0 +1,23 @@
+lib/libskstream-0.3.a
+lib/libskstream-0.3.so
+lib/libskstream-0.3.so.1
+libdata/pkgconfig/skstream-0.3.pc
+libdata/pkgconfig/skstream-unix-0.3.pc
+lib/skstream-0.3/include/skstream/skstreamconfig.h
+@dirrm lib/skstream-0.3/include/skstream
+@dirrm lib/skstream-0.3/include
+@dirrm lib/skstream-0.3
+include/skstream-0.3/skstream/skstream.h
+include/skstream-0.3/skstream/skstream_unix.h
+include/skstream-0.3/skstream/skserver.h
+include/skstream-0.3/skstream/skserver_unix.h
+include/skstream-0.3/skstream/skpoll.h
+include/skstream-0.3/skstream/sasproto.h
+@dirrm include/skstream-0.3/skstream
+@dirrm include/skstream-0.3
+%%DOCSDIR%%/README
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README.FreeSockets
+@dirrm %%DOCSDIR%%