aboutsummaryrefslogtreecommitdiffstats
path: root/net/socketpipe/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-09-01 19:07:58 +0800
committernetchild <netchild@FreeBSD.org>2003-09-01 19:07:58 +0800
commit38eaacc880ab15a563d9415b82e852baa0c0dd49 (patch)
tree7e0615d39c37065bd36ffbe3c267b073af66dcf5 /net/socketpipe/Makefile
parentbed71a400bd5309f858dcc0c022ef18c31887dc6 (diff)
downloadfreebsd-ports-gnome-38eaacc880ab15a563d9415b82e852baa0c0dd49.tar.gz
freebsd-ports-gnome-38eaacc880ab15a563d9415b82e852baa0c0dd49.tar.zst
freebsd-ports-gnome-38eaacc880ab15a563d9415b82e852baa0c0dd49.zip
Socketpipe connects over a TCP/IP socket a remote command to a local
input generation command and/or a local output processing command. The connection is made by redirecting the input/output file descriptors to the socket. This saves the context switching and data copying overhead associated with piping data through ssh(1) or rsh(1). Socketpipe must be installed on both machines and user authentication is still performed by a command like ssh(1) or rsh(1). The confidentiality and integrity of the data in transit is not protected against mallicious attacks; the command is designed for use in a trusted LAN environment. Submitted by: dds
Diffstat (limited to 'net/socketpipe/Makefile')
-rw-r--r--net/socketpipe/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/net/socketpipe/Makefile b/net/socketpipe/Makefile
new file mode 100644
index 000000000000..147eac1871b2
--- /dev/null
+++ b/net/socketpipe/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: socketpipe
+# Date created: 29 August 2003
+# Whom: dds
+#
+# $FreeBSD$
+#
+
+PORTNAME= socketpipe
+PORTVERSION= 1.3
+CATEGORIES= net
+MASTER_SITES= http://www.spinellis.gr/sw/unix/socketpipe/ \
+ http://www.dmst.aueb.gr/dds/sw/unix/socketpipe/
+
+MAINTAINER= dds@FreeBSD.org
+COMMENT= Zero overhead remote process plumbing
+
+MAN1= socketpipe.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>