aboutsummaryrefslogtreecommitdiffstats
path: root/net/socks5/Makefile
diff options
context:
space:
mode:
authorimp <imp@FreeBSD.org>1999-09-25 13:27:58 +0800
committerimp <imp@FreeBSD.org>1999-09-25 13:27:58 +0800
commitcf0b5642e7bf8bafd43a9121ceb4cef36bbfe139 (patch)
treef3fe7881ac71c10e97f750defacf9b6ec59fa3ca /net/socks5/Makefile
parent26953ecac8949e883023e8f03c48bfd7098f3886 (diff)
downloadfreebsd-ports-gnome-cf0b5642e7bf8bafd43a9121ceb4cef36bbfe139.tar.gz
freebsd-ports-gnome-cf0b5642e7bf8bafd43a9121ceb4cef36bbfe139.tar.zst
freebsd-ports-gnome-cf0b5642e7bf8bafd43a9121ceb4cef36bbfe139.zip
Upgrade to 1.0 r10.
Remove patches integrated since r9. 1/2 of patch-aa was integrated, the second half has been retained. Add new patch (patch-ak) from web site for s5fakehost files. Add new patch (patch-al) to fix long standing telnet failure to build (it is a kludge, so hasn't been submitted to the socks maintainers).
Diffstat (limited to 'net/socks5/Makefile')
-rw-r--r--net/socks5/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/net/socks5/Makefile b/net/socks5/Makefile
index 9f0d4ab9ac2b..4c9179ac1018 100644
--- a/net/socks5/Makefile
+++ b/net/socks5/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: socks5
-# Version required: v1.0r8
+# Version required: v1.0r10
# Date created: 24 Apr 1996
# Whom: pst
#
# $FreeBSD$
#
-DISTNAME= socks5-v1.0r9
-PKGNAME= socks5-1.0.9
+DISTNAME= socks5-v1.0r10
+PKGNAME= socks5-1.0.10
CATEGORIES= net security
EXTRACT_SUFX= .tar.gz
@@ -33,6 +33,7 @@ CONFIGURE_ARGS= --with-libconffile=${PREFIX}/etc/libsocks5.conf \
${EXTRA_CONFIGURE_ARGS}
MAN1= runsocks.1 socks5.1 stopsocks.1 socks5_clients.1
MAN5= libsocks5.conf.5 socks5.conf.5
+CONFIGURE_ENV= LIBS=-lcrypt
do-fetch:
@if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
@@ -46,17 +47,3 @@ do-fetch:
fi
.include <bsd.port.mk>
-
-# the following need to be included after bsd.port.mk, since OPSYS
-# ARCH are defined in bsd.port.mk
-
-.if ${OPSYS} == "FreeBSD"
-CONFIGURE_ENV= LIBS=-lcrypt
-.endif
-
-# OpenBSD/arc doesn't seem to have a working ldconfig
-
-.if ${OPSYS} != "OpenBSD" || ${ARCH} != "arc"
-post-install:
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-.endif