aboutsummaryrefslogtreecommitdiffstats
path: root/net/spnetkit
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2011-06-21 09:58:12 +0800
committervanilla <vanilla@FreeBSD.org>2011-06-21 09:58:12 +0800
commit2cd34fe79d81f15d341fc6ed415fe0ff4b87e7e1 (patch)
tree2882566dcc81c53bf8d997bb7be08265711a40ea /net/spnetkit
parent0ea825582027f4cb3214ff37516437e261413f6a (diff)
downloadfreebsd-ports-gnome-2cd34fe79d81f15d341fc6ed415fe0ff4b87e7e1.tar.gz
freebsd-ports-gnome-2cd34fe79d81f15d341fc6ed415fe0ff4b87e7e1.tar.zst
freebsd-ports-gnome-2cd34fe79d81f15d341fc6ed415fe0ff4b87e7e1.zip
Upgrade to 0.3, and fix build with clang.
Diffstat (limited to 'net/spnetkit')
-rw-r--r--net/spnetkit/Makefile10
-rw-r--r--net/spnetkit/distinfo4
-rw-r--r--net/spnetkit/files/patch-Makefile8
-rw-r--r--net/spnetkit/files/patch-port.mk14
-rw-r--r--net/spnetkit/files/patch-spnklog.cpp10
-rw-r--r--net/spnetkit/files/patch-spnksocket.hpp10
-rw-r--r--net/spnetkit/files/patch-testhttpcli.cpp11
-rw-r--r--net/spnetkit/files/patch-testmemcli.cpp11
-rw-r--r--net/spnetkit/files/patch-testmemproto.cpp11
-rw-r--r--net/spnetkit/pkg-plist4
10 files changed, 30 insertions, 63 deletions
diff --git a/net/spnetkit/Makefile b/net/spnetkit/Makefile
index 172752f85c7d..293eee14b3f9 100644
--- a/net/spnetkit/Makefile
+++ b/net/spnetkit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= spnetkit
-PORTVERSION= 0.2.0
+PORTVERSION= 0.3.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -22,9 +22,9 @@ ALL_TARGET= all ssl
do-install:
@${MKDIR} ${PREFIX}/include/spnetkit
@${INSTALL} ${WRKSRC}/*.hpp ${PREFIX}/include/spnetkit
- @${INSTALL} ${WRKSRC}/libspnetkit.so.0 ${PREFIX}/lib
- @${LN} -s ${PREFIX}/lib/libspnetkit.so.0 ${PREFIX}/lib/libspnetkit.so
- @${INSTALL} ${WRKSRC}/libspnetkit_s.so.0 ${PREFIX}/lib
- @${LN} -s ${PREFIX}/lib/libspnetkit_s.so.0 ${PREFIX}/lib/libspnetkit_s.so
+ @${INSTALL} ${WRKSRC}/libspnetkit.so ${PREFIX}/lib/libspnetkit.so.0
+ @${LN} -sf ${PREFIX}/lib/libspnetkit.so.0 ${PREFIX}/lib/libspnetkit.so
+ @${INSTALL} ${WRKSRC}/libspnetkit_s.so ${PREFIX}/lib/libspnetkit_s.so.0
+ @${LN} -sf ${PREFIX}/lib/libspnetkit_s.so.0 ${PREFIX}/lib/libspnetkit_s.so
.include <bsd.port.mk>
diff --git a/net/spnetkit/distinfo b/net/spnetkit/distinfo
index 1f91fb771d82..424edfc6cd13 100644
--- a/net/spnetkit/distinfo
+++ b/net/spnetkit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (spnetkit-0.2.0.src.tar.gz) = a37c30936e764f47b70459c20a13f0a0d75842d9a0856a7c8e9962ba89c47455
-SIZE (spnetkit-0.2.0.src.tar.gz) = 48207
+SHA256 (spnetkit-0.3.0.src.tar.gz) = 8127f0dd85452d0107e7c8784de358184b0113a55899c4cde6c02062172006f7
+SIZE (spnetkit-0.3.0.src.tar.gz) = 62642
diff --git a/net/spnetkit/files/patch-Makefile b/net/spnetkit/files/patch-Makefile
deleted file mode 100644
index 815d11f6db9a..000000000000
--- a/net/spnetkit/files/patch-Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
---- Makefile.orig 2008-02-18 14:11:22.000000000 +0800
-+++ Makefile 2008-02-18 14:10:32.000000000 +0800
-@@ -1,3 +1,5 @@
-+version = 0
-+
- include ../port/port.mk
-
- #--------------------------------------------------------------------
diff --git a/net/spnetkit/files/patch-port.mk b/net/spnetkit/files/patch-port.mk
new file mode 100644
index 000000000000..17a876bdaf1b
--- /dev/null
+++ b/net/spnetkit/files/patch-port.mk
@@ -0,0 +1,14 @@
+--- ../port/port.mk.orig 2008-02-17 15:31:19.000000000 +0800
++++ ../port/port.mk 2011-06-21 09:21:17.000000000 +0800
+@@ -1,9 +1,9 @@
+
+ #--------------------------------------------------------------------
+
+-CC = gcc
++#CC = gcc
+ AR = ar cru
+-CFLAGS = -Wall -D_REENTRANT -D_GNU_SOURCE -g -fPIC
++CFLAGS += -Wall -D_REENTRANT -D_GNU_SOURCE -g -fPIC
+ SOFLAGS = -shared -Wl,-h,$@
+ LDFLAGS = -lstdc++ -lpthread
+
diff --git a/net/spnetkit/files/patch-spnklog.cpp b/net/spnetkit/files/patch-spnklog.cpp
index c4784107c742..e6ca7380dda4 100644
--- a/net/spnetkit/files/patch-spnklog.cpp
+++ b/net/spnetkit/files/patch-spnklog.cpp
@@ -1,11 +1,11 @@
---- spnklog.cpp.orig 2008-02-18 12:19:32.000000000 +0800
-+++ spnklog.cpp 2008-02-18 12:19:41.000000000 +0800
-@@ -107,7 +107,7 @@
+--- spnklog.cpp.orig 2011-06-21 09:28:36.000000000 +0800
++++ spnklog.cpp 2011-06-21 09:29:24.000000000 +0800
+@@ -168,7 +168,7 @@ void SP_NKLog :: log( int pri, const cha
snprintf( logText, sizeof( logText ),
"%04i-%02i-%02i %02i:%02i:%02i #%i ",
1900 + tmTime.tm_year, tmTime.tm_mon+1, tmTime.tm_mday,
-- tmTime.tm_hour, tmTime.tm_min, tmTime.tm_sec, (int)pthread_self() );
-+ tmTime.tm_hour, tmTime.tm_min, tmTime.tm_sec, pthread_self() );
+- tmTime.tm_hour, tmTime.tm_min, tmTime.tm_sec, (int)spnk_threadid() );
++ tmTime.tm_hour, tmTime.tm_min, tmTime.tm_sec, (long)spnk_threadid() );
}
if( mIsLogPriName ) {
diff --git a/net/spnetkit/files/patch-spnksocket.hpp b/net/spnetkit/files/patch-spnksocket.hpp
deleted file mode 100644
index 6635eedcf42b..000000000000
--- a/net/spnetkit/files/patch-spnksocket.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- spnksocket.hpp.orig 2008-02-18 12:21:26.000000000 +0800
-+++ spnksocket.hpp 2008-02-18 12:21:43.000000000 +0800
-@@ -6,6 +6,7 @@
- #ifndef __spnksocket_hpp__
- #define __spnksocket_hpp__
-
-+#include <sys/time.h>
- #include <sys/socket.h>
-
- class SP_NKSocket {
diff --git a/net/spnetkit/files/patch-testhttpcli.cpp b/net/spnetkit/files/patch-testhttpcli.cpp
deleted file mode 100644
index 79d6b440b907..000000000000
--- a/net/spnetkit/files/patch-testhttpcli.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- testhttpcli.cpp.orig 2008-02-18 12:22:11.000000000 +0800
-+++ testhttpcli.cpp 2008-02-18 12:24:00.000000000 +0800
-@@ -35,7 +35,7 @@
-
- int main( int argc, char * argv[] )
- {
-- assert ( sigset ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
-+ assert ( signal ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
-
- SP_NKLog::init4test( "testhttpcli" );
- SP_NKLog::setLogLevel( LOG_DEBUG );
diff --git a/net/spnetkit/files/patch-testmemcli.cpp b/net/spnetkit/files/patch-testmemcli.cpp
deleted file mode 100644
index eccf81a36176..000000000000
--- a/net/spnetkit/files/patch-testmemcli.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- testmemcli.cpp.orig 2008-02-18 12:24:33.000000000 +0800
-+++ testmemcli.cpp 2008-02-18 12:24:40.000000000 +0800
-@@ -98,7 +98,7 @@
-
- int main( int argc, char * argv[] )
- {
-- assert ( sigset ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
-+ assert ( signal ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
-
- const char * config = "testmemcli.ini";
- int loops = 100;
diff --git a/net/spnetkit/files/patch-testmemproto.cpp b/net/spnetkit/files/patch-testmemproto.cpp
deleted file mode 100644
index 60cac773d7b1..000000000000
--- a/net/spnetkit/files/patch-testmemproto.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- testmemproto.cpp.orig 2008-02-18 12:24:14.000000000 +0800
-+++ testmemproto.cpp 2008-02-18 12:24:24.000000000 +0800
-@@ -138,7 +138,7 @@
-
- int main( int argc, char * argv[] )
- {
-- assert ( sigset ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
-+ assert ( signal ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
-
- const char * host = "127.0.0.1";
- int port = 11211, loops = 100;
diff --git a/net/spnetkit/pkg-plist b/net/spnetkit/pkg-plist
index d96d698549cc..c8e573b3f99a 100644
--- a/net/spnetkit/pkg-plist
+++ b/net/spnetkit/pkg-plist
@@ -4,12 +4,15 @@ include/spnetkit/spnkfile.hpp
include/spnetkit/spnkhash.hpp
include/spnetkit/spnkhttpcli.hpp
include/spnetkit/spnkhttpmsg.hpp
+include/spnetkit/spnkicapcli.hpp
include/spnetkit/spnkini.hpp
include/spnetkit/spnklist.hpp
include/spnetkit/spnklog.hpp
include/spnetkit/spnkmemcli.hpp
include/spnetkit/spnkmemobj.hpp
+include/spnetkit/spnkmiltercli.hpp
include/spnetkit/spnkpop3cli.hpp
+include/spnetkit/spnkporting.hpp
include/spnetkit/spnkreader.hpp
include/spnetkit/spnksmtpaddr.hpp
include/spnetkit/spnksmtpcli.hpp
@@ -17,6 +20,7 @@ include/spnetkit/spnksocket.hpp
include/spnetkit/spnksocketpool.hpp
include/spnetkit/spnksslsocket.hpp
include/spnetkit/spnkstr.hpp
+include/spnetkit/spnkthread.hpp
include/spnetkit/spnktime.hpp
lib/libspnetkit.so
lib/libspnetkit.so.0