aboutsummaryrefslogtreecommitdiffstats
path: root/net/spread-j/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-30 09:39:54 +0800
committeredwin <edwin@FreeBSD.org>2003-08-30 09:39:54 +0800
commit9e6fd730b7df0e70c55daf14df5d6ff53a2d5fd7 (patch)
treecb9981d6ad7c3724e3b63a49c8978de8c75f1965 /net/spread-j/Makefile
parent314d43b458d1b0d59ffef69e99cff152033f54ee (diff)
downloadfreebsd-ports-gnome-9e6fd730b7df0e70c55daf14df5d6ff53a2d5fd7.tar.gz
freebsd-ports-gnome-9e6fd730b7df0e70c55daf14df5d6ff53a2d5fd7.tar.zst
freebsd-ports-gnome-9e6fd730b7df0e70c55daf14df5d6ff53a2d5fd7.zip
New port (split out from old port): net/spread-j
This port contains just the java client libraries, which have been split from the net/spread port to make them easier to find, build and include, as a separate port. PR: ports/45180 Submitted by: Joshua Goodall <joshua@roughtrade.net>
Diffstat (limited to 'net/spread-j/Makefile')
-rw-r--r--net/spread-j/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/net/spread-j/Makefile b/net/spread-j/Makefile
new file mode 100644
index 000000000000..bab75f8b5dfe
--- /dev/null
+++ b/net/spread-j/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: spread-j
+# Date created: 06 November 2002
+# Whom: Joshua Goodall <joshua@roughtrade.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spread-j
+PORTVERSION= 3.17.0
+PORTREVISION= 1
+CATEGORIES= net java
+MASTER_SITES= http://www.roughtrade.net/distfiles/
+DISTNAME= spread-src-${PORTVERSION}
+
+MAINTAINER= joshua@roughtrade.net
+COMMENT= Java client library for the Spread Group Communication System
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
+
+USE_JAVA= 1.2+
+JAVALIBDIR= ${PREFIX}/share/java/classes
+PKGMESSAGE= ${WRKSRC}/../license.txt
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= JAVALIB_DOCS='@comment '
+.else
+PLIST_SUB+= JAVALIB_DOCS=''
+.endif
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/java
+PLIST_SUB+= JAVALIBDIR=share/java/classes
+ANT?= ${LOCALBASE}/bin/ant
+
+do-build:
+ @cd ${WRKSRC} && ${ANT} javadocs jar -Dlib.dir=${JAVALIBDIR} -Djavadoc.destdir=docs
+
+do-install:
+ @cd ${WRKSRC} && ${ANT} install -Dlib.dir=${JAVALIBDIR}
+ ${INSTALL} -d -o root -g wheel -m 0755 ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/recThread.java ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Flooder.java ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/User.java ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}/html
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}/html/spread
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}/html/spread/class-use
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/docs/stylesheet.css ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/docs/spread/*.html ${DOCSDIR}/html/spread
+ ${INSTALL_DATA} ${WRKSRC}/docs/spread/class-use/*.html ${DOCSDIR}/html/spread/class-use
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>