aboutsummaryrefslogtreecommitdiffstats
path: root/net/ssldump/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2008-01-30 00:03:18 +0800
committerdanfe <danfe@FreeBSD.org>2008-01-30 00:03:18 +0800
commit70d6518eaa0bf66416c901a1f7becfe13467b199 (patch)
tree4ad0f36865b4c2d50901c6d7fe74c0875cbe9d76 /net/ssldump/Makefile
parenta8718a97aa00fa42a128ceb92aa801de31e1f606 (diff)
downloadfreebsd-ports-gnome-70d6518eaa0bf66416c901a1f7becfe13467b199.tar.gz
freebsd-ports-gnome-70d6518eaa0bf66416c901a1f7becfe13467b199.tar.zst
freebsd-ports-gnome-70d6518eaa0bf66416c901a1f7becfe13467b199.zip
- Fix "Couldn't create network handler" error [1]
- Revise manual page for correctness and completeness - Reinstate the `-y' (nroff) flag - Drop gmake(1) dependency, builds with BSD make(1) - Tweak port description and Makefile markup and syntax - Pet portlint(1) Mentioned in PR: ports/119680 [1] Patches obtained from: Debian
Diffstat (limited to 'net/ssldump/Makefile')
-rw-r--r--net/ssldump/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/net/ssldump/Makefile b/net/ssldump/Makefile
index 393593d592e3..8cda1bef385b 100644
--- a/net/ssldump/Makefile
+++ b/net/ssldump/Makefile
@@ -1,35 +1,34 @@
# New ports collection makefile for: ssldump
-# Date created: 10 November 2000
-# Whom: Kris Kennaway <kris@FreeBSD.org>
+# Date created: 10 November 2000
+# Whom: Kris Kennaway <kris@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ssldump
PORTVERSION= 0.9b3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net security
MASTER_SITES= http://www.rtfm.com/ssldump/
MAINTAINER= ports@FreeBSD.org
COMMENT= SSLv3/TLS network protocol analyzer
-USE_OPENSSL= YES
+USE_OPENSSL= yes
-OPTIONS= AES "Enable AES support from CVS (EXPERIMENTAL)" off
-
-.include <bsd.port.pre.mk>
-
-GNU_CONFIGURE= YES
-USE_GMAKE= YES
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE} \
--sbindir=${PREFIX}/bin
+OPTIONS= AES "Enable AES support from CVS (EXPERIMENTAL)" off
+
MAN1= ssldump.1
PLIST_FILES= bin/ssldump
-.if defined (WITH_AES)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aes
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_AES)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aes
.endif
.include <bsd.port.post.mk>