aboutsummaryrefslogtreecommitdiffstats
path: root/net/stone/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-01-09 21:56:03 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-01-09 21:56:03 +0800
commitdee8a10e9dedbcb3fa7b2a8bce0b75b131f5437d (patch)
tree5e1811eeb9edb052c00ac0b58375e2541215fe35 /net/stone/Makefile
parentc03047ee0f2b8027ac04a886fdb7a17f89d59416 (diff)
downloadfreebsd-ports-gnome-dee8a10e9dedbcb3fa7b2a8bce0b75b131f5437d.tar.gz
freebsd-ports-gnome-dee8a10e9dedbcb3fa7b2a8bce0b75b131f5437d.tar.zst
freebsd-ports-gnome-dee8a10e9dedbcb3fa7b2a8bce0b75b131f5437d.zip
- Update to 2.3
- New version has IPv6 support, thus add to ipv6 sub category - Provide rcNG script - Install config file PR: 91547 Submitted by: Yoshihiko Sarumaru <mistral@imasy.or.jp> (maintainer)
Diffstat (limited to 'net/stone/Makefile')
-rw-r--r--net/stone/Makefile56
1 files changed, 26 insertions, 30 deletions
diff --git a/net/stone/Makefile b/net/stone/Makefile
index 4a3e6c9ee3e3..6b5b9cd8606e 100644
--- a/net/stone/Makefile
+++ b/net/stone/Makefile
@@ -6,48 +6,44 @@
#
PORTNAME= stone
-PORTVERSION= 2.2c
-CATEGORIES= net
+PORTVERSION= 2.3
+CATEGORIES= net ipv6
MASTER_SITES= http://www.gcd.org/sengoku/stone/
MAINTAINER= mistral@imasy.or.jp
COMMENT= Stone is a TCP/IP packet repeater in the application layer
-MAN1= ${PORTNAME}.1
+MAN1= stone.1
MANLANG= "" ja
-PLIST_FILES= bin/stone
-USE_REINPLACE= yes
+USE_RC_SUBR= stone.sh
+USE_OPENSSL= yes
+USE_REINPLACE= yes
-.if exists(${PREFIX}/lib/libssl.so)
-ALL_TARGET= bsd-ssl
-MAKE_ARGS= -e SSL_FLAGS="-DUSE_SSL -I${PREFIX}/include" SSL_LIBS="-L${PREFIX}/lib -lssl -lcrypto"
-.elif exists(/usr/lib/libssl.so)
-ALL_TARGET= bsd-ssl
-MAKE_ARGS= -e SSL_FLAGS="-DUSE_SSL" SSL_LIBS="-lssl -lcrypto"
-.else
-ALL_TARGET= bsd-pop
-MAKE_ARGS= -e POP_LIBS="-lmd"
-NEED_GLOBAL_H= yes
-.endif
-
-pre-everything::
-.if ${ALL_TARGET} != bsd-ssl
- @${ECHO_CMD} "You can build stone with SSL support by installing OpenSSL."
-.endif
+.include <bsd.port.pre.mk>
-pre-patch:
- ${REINPLACE_CMD} -e "s/-D_THREAD_SAFE/${PTHREAD_CFLAGS}/g;s/-pthread/${PTHREAD_LIBS}/g" ${WRKSRC}/Makefile
-
-pre-build:
-.if defined(NEED_GLOBAL_H)
+.if defined(WITHOUT_SSL)
+.undef USE_OPENSSL
+ALL_TARGET= bsd-pop
+MAKE_ARGS= POP_LIBS="-lmd" LIBS="-DUNIX_DAEMON"
+post-extract:
${TOUCH} ${WRKSRC}/global.h
+.else
+ALL_TARGET= bsd-ssl
+MAKE_ARGS= SSL_FLAGS="-DUSE_SSL -I${OPENSSLINC}" \
+ SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto" LIBS="-DUNIX_DAEMON"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/${MAKEFILE}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stone ${PREFIX}/bin/stone
- ${INSTALL_MAN} ${WRKSRC}/stone.1 ${PREFIX}/man/man1/stone.1
- ${INSTALL_MAN} ${WRKSRC}/stone.1.ja ${PREFIX}/man/ja/man1/stone.1
+ ${INSTALL_MAN} ${FILESDIR}/stone.1 ${PREFIX}/man/man1/stone.1
+ ${INSTALL_MAN} ${FILESDIR}/stone.1.ja ${PREFIX}/man/ja/man1/stone.1
+ ${INSTALL_DATA} ${FILESDIR}/stone.cnf ${PREFIX}/etc/stone.cnf.sample
+.if !exists(${PREFIX}/etc/stone.cnf)
+ ${INSTALL_DATA} ${FILESDIR}/stone.cnf ${PREFIX}/etc
+.endif
-#.include <bsd.port.post.mk>
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>