aboutsummaryrefslogtreecommitdiffstats
path: root/net/svnup
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-04-17 06:00:28 +0800
committerjgh <jgh@FreeBSD.org>2013-04-17 06:00:28 +0800
commit007714ad2a87c7cb18f21da1650747c94d22c142 (patch)
tree717b48a5a23e8dc799330b7d55f7c81135a82df0 /net/svnup
parentfaa1a64758a115db42ab83b6feaeef48ee1e4906 (diff)
downloadfreebsd-ports-gnome-007714ad2a87c7cb18f21da1650747c94d22c142.tar.gz
freebsd-ports-gnome-007714ad2a87c7cb18f21da1650747c94d22c142.tar.zst
freebsd-ports-gnome-007714ad2a87c7cb18f21da1650747c94d22c142.zip
- update to 0.62
- adjust mirror priorities based on availability svnup-0.62 - 11 April 2013 * Implemented binary search tree for faster lookups of "known files". * Added support for handling symbolic links in the repository. * Fixed a bug where file names with hex encoded characters sent during http transfers weren't properly decoded. * Fixed bug when allocating space for the /tmp/svnup directory - special thanks to (Ilya A. Arkhipov <m1cro@rambler-co.ru>). * Fixed bug where incorrect number of bytes were sent in send_command - special thanks to <boco@ufanet.ru>. svnup-0.61 - 6 April 2013 * Fixed a bug with file deletion. * Minor speed improvement with "known file" lookup. * Fixed several valgrind-detected small memory leaks. * Fixed a segfault when https:// was added to a -h parameter. svnup-0.60 - 3 April 2013 * http/https support added. * added support for a configuration/preferences/aliases file. * added IPv6 support. PR: 177614 [1] PR: 177777 Submitted by: maintainer, jgh@, zi@ [1] Approved by: maintainer, jcm@visi.com Feature safe: yes
Diffstat (limited to 'net/svnup')
-rw-r--r--net/svnup/Makefile36
-rw-r--r--net/svnup/distinfo4
-rw-r--r--net/svnup/pkg-plist4
3 files changed, 35 insertions, 9 deletions
diff --git a/net/svnup/Makefile b/net/svnup/Makefile
index a2a7dc76fe2c..8efeb7811412 100644
--- a/net/svnup/Makefile
+++ b/net/svnup/Makefile
@@ -1,28 +1,50 @@
# $FreeBSD$
PORTNAME= svnup
-PORTVERSION= 0.56
+PORTVERSION= 0.62
CATEGORIES= net
MASTER_SITES= http://jcm.dsl.visi.com/freebsd/svnup/ \
- LOCAL/bdrewery/${PORTNAME}/
+ LOCAL/jgh/net/${PORTNAME}/ \
+ LOCAL/bdrewery/${PORTNAME}/ \
+ http://mirrors.rit.edu/zi/
MAINTAINER= jcm@visi.com
-COMMENT= Lightweight program to pull source using the svn protocol
+COMMENT= Lightweight program to pull source from an Apache Subversion server.
LICENSE= BSD
-LDFLAGS+= -lmd
+LDFLAGS+= -lmd -lssl
USE_XZ= yes
MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
+MAN5= ${PORTNAME}.conf.5
+PORTDOCS= ChangeLog
+
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|8.3|${OSREL}|' ${WRKSRC}/svnup.conf
do-build:
cd ${WRKSRC} && \
${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+.include <bsd.port.options.mk>
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${MAN5} ${MAN5PREFIX}/man/man5
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
+ @if [ ! -e "${PREFIX}/etc/${PORTNAME}.conf" ]; then \
+ ${ECHO_MSG} " Installing local configuration file: ${PREFIX}/etc/${PORTNAME}.conf"; \
+ ${CP} ${PREFIX}/etc/${PORTNAME}.conf.sample ${PREFIX}/etc/${PORTNAME}.conf; \
+ else \
+ ${ECHO_MSG} " Preserving local configuration file: ${ETCDIR}/${PORTNAME}.conf"; \
+ fi
.include <bsd.port.mk>
diff --git a/net/svnup/distinfo b/net/svnup/distinfo
index 43c3ad716366..263e68c577b5 100644
--- a/net/svnup/distinfo
+++ b/net/svnup/distinfo
@@ -1,2 +1,2 @@
-SHA256 (svnup-0.56.tar.xz) = ef7bf9d6e11d7333d459e770e94dd9062219b7b174781b9f8e63bbc3b2926a03
-SIZE (svnup-0.56.tar.xz) = 9536
+SHA256 (svnup-0.62.tar.xz) = 8dbff5157c1508972a601aeca1ae3b68fe459ce88f8b2f3a1efac6b57c44a3b8
+SIZE (svnup-0.62.tar.xz) = 17860
diff --git a/net/svnup/pkg-plist b/net/svnup/pkg-plist
new file mode 100644
index 000000000000..300d980af819
--- /dev/null
+++ b/net/svnup/pkg-plist
@@ -0,0 +1,4 @@
+bin/svnup
+@unexec if cmp -s %D/etc/svnup.conf.sample %D/etc/svnup.conf; then rm -f %D/etc/svnup.conf; else echo "If permanently removing this package, then please consider removing %D/etc/svnup.conf" ;fi
+etc/svnup.conf.sample
+@exec if [ ! -f %D/etc/svnup.conf ] ; then cp -p %D/etc/svnup.conf.sample %D/etc/svnup.conf; fi