aboutsummaryrefslogtreecommitdiffstats
path: root/net/tcpdump/Makefile
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2003-12-11 22:03:35 +0800
committerbms <bms@FreeBSD.org>2003-12-11 22:03:35 +0800
commitbf3d275a54984db626556526bba26e3fc7db9e03 (patch)
treee3b1581baaa9299cb4394ba9dbea17270139ebc8 /net/tcpdump/Makefile
parentf1f1e4e30a8bc1edecea525b039e6804b7b99a3a (diff)
downloadfreebsd-ports-gnome-bf3d275a54984db626556526bba26e3fc7db9e03.tar.gz
freebsd-ports-gnome-bf3d275a54984db626556526bba26e3fc7db9e03.tar.zst
freebsd-ports-gnome-bf3d275a54984db626556526bba26e3fc7db9e03.zip
Add a new option, WITH_RADIOTAP. Import David Young's patches for using the
new net80211 radiotap interface. This can be activated once the tcpdump port is built and installed using the datalink type IEEE802_11_RADIO. Tested with a wi(4), OEM PRISM2, 1.4.9 STA firmware. Submitted by: David Young Sponsored by: consume.net
Diffstat (limited to 'net/tcpdump/Makefile')
-rw-r--r--net/tcpdump/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index db7bc0698ca3..1ee23e841214 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -30,6 +30,15 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --without-crypto
.endif
+.if defined(WITH_RADIOTAP)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.in \
+ ${PATCHDIR}/extra-patch-cpack.c \
+ ${PATCHDIR}/extra-patch-cpack.h \
+ ${PATCHDIR}/extra-patch-extract.h \
+ ${PATCHDIR}/extra-patch-ieee802_11_radio.h \
+ ${PATCHDIR}/extra-patch-print-802_11.c
+.endif
+
LOCALPCAPDIR= ${WRKDIR}/libpcap-0.8.1
LOCALPCAPFILES= include/pcap.h include/pcap-namedb.h include/pcap-bpf.h \
lib/libpcap.a