aboutsummaryrefslogtreecommitdiffstats
path: root/net/tdetect
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1999-07-05 03:18:49 +0800
committerobrien <obrien@FreeBSD.org>1999-07-05 03:18:49 +0800
commit12d47b30d33bfcb0ce351be87a84da713ec93f31 (patch)
treef3d689d97a9cf91ce18b5964c0e22bf5bc74d815 /net/tdetect
parent5ae83f09e1ed67ef9d45196c2887d15f06268c02 (diff)
downloadfreebsd-ports-gnome-12d47b30d33bfcb0ce351be87a84da713ec93f31.tar.gz
freebsd-ports-gnome-12d47b30d33bfcb0ce351be87a84da713ec93f31.tar.zst
freebsd-ports-gnome-12d47b30d33bfcb0ce351be87a84da713ec93f31.zip
The lines creating PREFIX/etc/rc.d/tdetect.sh were totally bogus.
The resulting file was obviously never looked at by the maintainer.
Diffstat (limited to 'net/tdetect')
-rw-r--r--net/tdetect/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net/tdetect/Makefile b/net/tdetect/Makefile
index 3652fee5f5a1..0f6e767c9578 100644
--- a/net/tdetect/Makefile
+++ b/net/tdetect/Makefile
@@ -4,7 +4,7 @@
# Date created: Sun Jan 31, 1997
# Whom: shipley@dis.org
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/05/03 02:49:34 steve Exp $
#
DISTNAME= tdetect-0.2
@@ -26,10 +26,13 @@ post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/tdetect.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/tdetect.sh startup file."; \
${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/tdetect.sh; \
- ${ECHO} "ethernetdev=ed0" > ${PREFIX}/etc/rc.d/tdetect.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/tdetect ] && ${PREFIX}/sbin/tdetect \$ethernetdev && echo -n ' tdetect'" >> ${PREFIX}/etc/rc.d/tdetect.sh; \
+ ${ECHO} "ETHERNETDEV=ed0" >> ${PREFIX}/etc/rc.d/tdetect.sh; \
+ ${ECHO} '[ -x ${PREFIX}/sbin/tdetect ] && ${PREFIX}/sbin/tdetect \$ETHERNETDEV && echo -n " tdetect"' >> ${PREFIX}/etc/rc.d/tdetect.sh; \
chmod 750 ${PREFIX}/etc/rc.d/tdetect.sh; \
- ${ECHO} "IMPORTANT ${PREFIX}/etc/rc.d/tdetect.sh and set ethernetdev to the name of the ethernetdev you wish to monitor"; \
+ ${ECHO} ''; \
+ ${ECHO} 'IMPORTANT edit ${PREFIX}/etc/rc.d/tdetect.sh and set "ETHERNETDEV" to'; \
+ ${ECHO} "the name of the ethernetdev you wish to monitor"; \
+ ${ECHO} ''; \
fi
.include <bsd.port.mk>