aboutsummaryrefslogtreecommitdiffstats
path: root/net/thcrut/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2001-08-23 20:52:04 +0800
committerkris <kris@FreeBSD.org>2001-08-23 20:52:04 +0800
commit94c274e33f64bc097d19d81f30214f8458637e15 (patch)
tree46f707032da8fad84b66070ccf5c21cd79a4d250 /net/thcrut/Makefile
parent8480bfb164241b49e51e1a3be1083865de1c8054 (diff)
downloadfreebsd-ports-gnome-94c274e33f64bc097d19d81f30214f8458637e15.tar.gz
freebsd-ports-gnome-94c274e33f64bc097d19d81f30214f8458637e15.tar.zst
freebsd-ports-gnome-94c274e33f64bc097d19d81f30214f8458637e15.zip
Add thc-rut 0.1
RUT (pronouced as 'root') mean 'aRe yoU There'. It was developed to brute force its way into wvlan (IEEE 802.11b) access points which use mac authentification. It offers a wide range of _local_ network discovery features like arp lookup on all hosts on a network with vendor-string, spoofed DHCP request, RARP, BOOTP, ICMP-ping and address mask request and some other features. Obtained from: OpenBSD
Diffstat (limited to 'net/thcrut/Makefile')
-rw-r--r--net/thcrut/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/thcrut/Makefile b/net/thcrut/Makefile
new file mode 100644
index 000000000000..0ba4fb5f99c4
--- /dev/null
+++ b/net/thcrut/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: thcrut
+# Date created: 23 Aug 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thcrut
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.thehackerschoice.com/releases/
+
+MAINTAINER= kris@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --with-libnet=${LOCALBASE} \
+ --sysconfdir=${PREFIX}/share/thcrut
+
+.include <bsd.port.mk>