aboutsummaryrefslogtreecommitdiffstats
path: root/net/throttled
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-06-14 15:51:42 +0800
committerale <ale@FreeBSD.org>2004-06-14 15:51:42 +0800
commit029708edfa09ef9081c34f637e9e9e0dd91a6fa4 (patch)
tree7dc500920285459eea391eb78ed24806be5eb568 /net/throttled
parent1d38d829e291cefb5fe79240b7d9ea9c3632e65c (diff)
downloadfreebsd-ports-gnome-029708edfa09ef9081c34f637e9e9e0dd91a6fa4.tar.gz
freebsd-ports-gnome-029708edfa09ef9081c34f637e9e9e0dd91a6fa4.tar.zst
freebsd-ports-gnome-029708edfa09ef9081c34f637e9e9e0dd91a6fa4.zip
Add throttled 0.3.2, bandwidth shaping and QoS solution.
PR: ports/67850 Submitted by: quest <quest@mac.com>
Diffstat (limited to 'net/throttled')
-rw-r--r--net/throttled/Makefile37
-rw-r--r--net/throttled/distinfo2
-rw-r--r--net/throttled/pkg-descr11
3 files changed, 50 insertions, 0 deletions
diff --git a/net/throttled/Makefile b/net/throttled/Makefile
new file mode 100644
index 000000000000..42f69b4f4851
--- /dev/null
+++ b/net/throttled/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: throttled
+# Date created: 11 Jun 2004
+# Whom: quest <quest@mac.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= throttled
+PORTVERSION= 0.3.2
+CATEGORIES= net
+MASTER_SITES= http://www.intrarts.com/Files/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= quest@mac.com
+COMMENT= Bandwidth shaping and QoS solution
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= sbin/throttled sbin/throttled-startup
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 499999
+IGNORE= "is for FreeBSD 4.X only"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|install: all|install: $$\{APPNAME\}|" \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/throttled-startup
+ @${REINPLACE_CMD} -e "s|c++|${CXX}|;s|-O3|${CXXFLAGS}|" \
+ ${WRKSRC}/src/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/net/throttled/distinfo b/net/throttled/distinfo
new file mode 100644
index 000000000000..fcd740986103
--- /dev/null
+++ b/net/throttled/distinfo
@@ -0,0 +1,2 @@
+MD5 (throttled-0.3.2.tgz) = d3e48c06ed3c8a4bf0017a37c213f4cb
+SIZE (throttled-0.3.2.tgz) = 182681
diff --git a/net/throttled/pkg-descr b/net/throttled/pkg-descr
new file mode 100644
index 000000000000..ec03d20d2c31
--- /dev/null
+++ b/net/throttled/pkg-descr
@@ -0,0 +1,11 @@
+throttled is a bandwidth shaping application for FreeBSD which allows you
+to cap your upstream bandwidth, prioritize ACK packets, and keep your
+download speeds high even when your server is sending out at full speed.
+It uses almost no cpu, and has a tiny footprint. Enjoy.
+
+For more information you can read the comments in throttled-startup
+
+WWW: http://www.intrarts.com/throttled.html
+
+- quest
+quest@mac.com