aboutsummaryrefslogtreecommitdiffstats
path: root/net/tn3270/Makefile
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>1999-08-31 04:27:51 +0800
committermarkm <markm@FreeBSD.org>1999-08-31 04:27:51 +0800
commitc49282e51cca54e843ebf537169466ba225e7b07 (patch)
tree03543dcc2c74904086c68b56ed30b3869d1402dc /net/tn3270/Makefile
parente73458487fc0248ea9cafe212a237b83010fa675 (diff)
downloadfreebsd-ports-gnome-c49282e51cca54e843ebf537169466ba225e7b07.tar.gz
freebsd-ports-gnome-c49282e51cca54e843ebf537169466ba225e7b07.tar.zst
freebsd-ports-gnome-c49282e51cca54e843ebf537169466ba225e7b07.zip
This is FreeBSD's tn3270, yanked from src/usr.bin, and lightly hacked
with the addition of relevant parts of src/usr.bin/telnet/* Once the dateline hase crossed the repository, the original will be led outside, given a perfunctory trial, and shot.
Diffstat (limited to 'net/tn3270/Makefile')
-rw-r--r--net/tn3270/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/tn3270/Makefile b/net/tn3270/Makefile
new file mode 100644
index 000000000000..380b8be81aae
--- /dev/null
+++ b/net/tn3270/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: tn3270
+# Version required: 4.4BSD-Lite
+# Date created: 30 August 1999
+# Whom: markm
+#
+# $FreeBSD$
+#
+
+DISTNAME= tn3270
+PKGNAME= tn3270-4.4
+CATEGORIES= net
+MASTER_SITES= http://freefall.freebsd.org/~markm/ \
+ ftp://ftp.za.freebsd.org/pub/FreeBSD/distfiles/ \
+ ftp://ftp3.za.freebsd.org/pub/FreeBSD/distfiles/
+
+MAINTAINER= markm@FreeBSD.ORG
+
+MAN1= tn3270.1 mset.1
+MAN5= map3270.5
+MANCOMPRESSED= maybe
+
+do-configure:
+ ${ECHO} "BINDIR= ${PREFIX}/bin" > ${WRKDIR}/Makefile.inc
+ ${ECHO} "MANDIR= ${PREFIX}/man/man" >> ${WRKDIR}/Makefile.inc
+do-build:
+ cd ${WRKSRC}; \
+ ${MAKE} depend; \
+ ${MAKE} all
+
+.include <bsd.port.mk>