aboutsummaryrefslogtreecommitdiffstats
path: root/net/tn5250/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-12-19 16:07:57 +0800
committersobomax <sobomax@FreeBSD.org>2000-12-19 16:07:57 +0800
commitf529edc4a0e8f114a05306a38b4043855e50ce87 (patch)
tree4599b24b1b294f45dc8cc222c600bc7667af9954 /net/tn5250/Makefile
parent6ef60c853eea3a65df65a7de698c1b2b230ac6bd (diff)
downloadfreebsd-ports-gnome-f529edc4a0e8f114a05306a38b4043855e50ce87.tar.gz
freebsd-ports-gnome-f529edc4a0e8f114a05306a38b4043855e50ce87.tar.zst
freebsd-ports-gnome-f529edc4a0e8f114a05306a38b4043855e50ce87.zip
- Update to version 0.16.0.
PR: 23628 Submitted by: Ports Furry
Diffstat (limited to 'net/tn5250/Makefile')
-rw-r--r--net/tn5250/Makefile22
1 files changed, 20 insertions, 2 deletions
diff --git a/net/tn5250/Makefile b/net/tn5250/Makefile
index 0ec083e664af..db2ec77229e4 100644
--- a/net/tn5250/Makefile
+++ b/net/tn5250/Makefile
@@ -6,15 +6,33 @@
#
PORTNAME= tn5250
-PORTVERSION= 0.15.8
+PORTVERSION= 0.16.0
CATEGORIES= net
-MASTER_SITES= ftp://cvs.cleveland.lug.net/pub/tn5250/
+MASTER_SITES= http://cvs.cleveland.lug.net/downloads/tn5250/
MAINTAINER= ports@FreeBSD.org
+USE_AUTOMAKE= yes
+AUTOMAKE_ARGS= --include-deps
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
MAN1= scs2ascii.1 scs2pdf.1 tn5250.1 lp5250d.1
+.if defined(WITH_SLANG)
+LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+PKGNAMESUFFIX= -slang
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --with-slang
+.endif
+
+.if !defined(WITH_SLANG)
+pre-everything:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with S/Lang support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SLANG=yes\""
+ @${ECHO_MSG}
+.endif
+
.include <bsd.port.mk>