aboutsummaryrefslogtreecommitdiffstats
path: root/net/trafcount/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-06-18 13:03:14 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-06-18 13:03:14 +0800
commitf1d1484cb4ae685c377e82bac79e086f0cd3e2e2 (patch)
tree30ff5aafafb5b99d8513e12bc63723985b76b3a7 /net/trafcount/Makefile
parent4560354df189ae29e0b972ed9eac6d1a83517ba4 (diff)
downloadfreebsd-ports-gnome-f1d1484cb4ae685c377e82bac79e086f0cd3e2e2.tar.gz
freebsd-ports-gnome-f1d1484cb4ae685c377e82bac79e086f0cd3e2e2.tar.zst
freebsd-ports-gnome-f1d1484cb4ae685c377e82bac79e086f0cd3e2e2.zip
Add trafcount, a "loadable module for freebsd lets admin see how much
amount of data was transfered by each user" PR: 27836 Submitted by: Amir S. <amir@boom.org.il>
Diffstat (limited to 'net/trafcount/Makefile')
-rw-r--r--net/trafcount/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/trafcount/Makefile b/net/trafcount/Makefile
new file mode 100644
index 000000000000..796b7821e891
--- /dev/null
+++ b/net/trafcount/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: trafcount
+# Date created: Sat Jun 2 16:29:22 IDT 2001
+# Whom: amir@boom.org.il
+#
+# $FreeBSD$
+#
+
+PORTNAME= trafcount
+PORTVERSION= 0.2.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= trafcount
+
+MAINTAINER= amir@boom.org.il
+
+STARTUP= trafcount.sh
+MAN1= trafcount.1
+
+MAN_COMPRESSED= no
+
+post-patch:
+ @${PERL} -pi.fbsd -e 's@kmoddir=/modules@kmoddir=${PREFIX}/libexec@g' ${WRKSRC}/trafcount.sh
+ @${PERL} -pi.fbsd -e 's@/usr/local@${PREFIX}@g' \
+ ${WRKSRC}/client/Makefile ${WRKSRC}/module/Makefile ${WRKSRC}/Makefile
+
+.if !exists(/usr/src/sys/Makefile)
+BROKEN= "Kernel source files required"
+.endif
+
+.include <bsd.port.mk>