aboutsummaryrefslogtreecommitdiffstats
path: root/net/trafcount
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 09:03:42 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 09:03:42 +0800
commit9e5efbaae957c805edd0943c1eca78c2b2ed2c53 (patch)
treebd8c255f5a9bd1bbafeb6cee3f6777775b3808ad /net/trafcount
parent6af9e7f948375241d9416047a1c2d9c9cf4a51bc (diff)
downloadfreebsd-ports-gnome-9e5efbaae957c805edd0943c1eca78c2b2ed2c53.tar.gz
freebsd-ports-gnome-9e5efbaae957c805edd0943c1eca78c2b2ed2c53.tar.zst
freebsd-ports-gnome-9e5efbaae957c805edd0943c1eca78c2b2ed2c53.zip
PERL -> REINPLACE
Noticed by: bento
Diffstat (limited to 'net/trafcount')
-rw-r--r--net/trafcount/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net/trafcount/Makefile b/net/trafcount/Makefile
index fd1a48da6454..d12f7bfa5447 100644
--- a/net/trafcount/Makefile
+++ b/net/trafcount/Makefile
@@ -19,11 +19,14 @@ STARTUP= trafcount.sh
MAN1= trafcount.1
MAN_COMPRESSED= no
+USE_REINPLACE= yes
post-patch:
- @${PERL} -pi.fbsd -e 's@kmoddir=/modules@kmoddir=${PREFIX}/libexec@g' ${WRKSRC}/trafcount.sh
- @${PERL} -pi.fbsd -e 's@/usr/local@${PREFIX}@g' \
- ${WRKSRC}/client/Makefile ${WRKSRC}/module/Makefile ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's@kmoddir=/modules@kmoddir=${PREFIX}/libexec@g' \
+ ${WRKSRC}/trafcount.sh
+ @${REINPLACE_CMD} -e 's@/usr/local@${PREFIX}@g' \
+ ${WRKSRC}/client/Makefile ${WRKSRC}/module/Makefile \
+ ${WRKSRC}/Makefile
.if !exists(/usr/src/sys/Makefile)
BROKEN= "Kernel source files required"