aboutsummaryrefslogtreecommitdiffstats
path: root/net/tryst/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-12-19 18:28:22 +0800
committerdinoex <dinoex@FreeBSD.org>2006-12-19 18:28:22 +0800
commit3a2b66b62b516d18244bfd032635642d1eaa940d (patch)
treed5778ad2a2dc9ba053ac717f1fe8122f1c80fea4 /net/tryst/Makefile
parent278f0d491e4a9f6236c2c59224c8069f7425aed9 (diff)
downloadfreebsd-ports-gnome-3a2b66b62b516d18244bfd032635642d1eaa940d.tar.gz
freebsd-ports-gnome-3a2b66b62b516d18244bfd032635642d1eaa940d.tar.zst
freebsd-ports-gnome-3a2b66b62b516d18244bfd032635642d1eaa940d.zip
Using Tryst, applications can discover what services are available on the
network, along with all necessary access information such as name, IP address, and port number for a given service. Bonjour allows you to register a network service, such as a printer or file server, so that it can be found by name or browsed for by service type and domain. WWW: http://gnustep.dyndns.org/
Diffstat (limited to 'net/tryst/Makefile')
-rw-r--r--net/tryst/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/tryst/Makefile b/net/tryst/Makefile
new file mode 100644
index 000000000000..c05ffdb8be41
--- /dev/null
+++ b/net/tryst/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tryst
+# Date created: 18 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tryst
+PORTVERSION= 1.0.8
+CATEGORIES= net
+MASTER_SITES= http://gnustep.dyndns.org/Downloads/
+DISTNAME= tryst-108pl4
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Implementation of Apples Bonjour for GNUstep
+
+LIB_DEPENDS= dns_sd:${PORTSDIR}/net/mDNSResponder
+
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+WRKSRC= ${WRKDIR}/Tryst-108.pl4
+
+.include <bsd.port.mk>