aboutsummaryrefslogtreecommitdiffstats
path: root/net/tucan
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2011-05-23 05:24:04 +0800
committermandree <mandree@FreeBSD.org>2011-05-23 05:24:04 +0800
commit74164919a7d6e47b8656bea6168081e45b7af954 (patch)
tree61f6dba0c5fb0fdc6ee1650977810f45b2289fd3 /net/tucan
parent5719d19873cf5caabbf45bf056d6c83b0bee3ae9 (diff)
downloadfreebsd-ports-gnome-74164919a7d6e47b8656bea6168081e45b7af954.tar.gz
freebsd-ports-gnome-74164919a7d6e47b8656bea6168081e45b7af954.tar.zst
freebsd-ports-gnome-74164919a7d6e47b8656bea6168081e45b7af954.zip
- Fix first-start failure by correcting permissions in ~/.tucan
(adds files/patch-core__service_config.py). - Bump PORTREVISION. - As the README says 'requires Python 2.5', state so in Makefile. - Modify COMMENT (maintainer note: limit 70 characters). - Remove *.orig file leftover from patching, to avoid installing it (it's not in pkg-plist) - Upgrade to newer upstream release shelved pending further maintainer PR (he rejected ports/155563 and wants to do his own). Reported by: Posé Sébastien <sebastien.pose@gmail.com> Fixed by: Gustau Pérez <gustau.perez@gmail.com> (maintainer) PR: ports/151572
Diffstat (limited to 'net/tucan')
-rw-r--r--net/tucan/Makefile13
-rw-r--r--net/tucan/files/patch-core__service_config.py19
-rw-r--r--net/tucan/pkg-descr11
3 files changed, 38 insertions, 5 deletions
diff --git a/net/tucan/Makefile b/net/tucan/Makefile
index ab762a59e4be..396d3d791ed3 100644
--- a/net/tucan/Makefile
+++ b/net/tucan/Makefile
@@ -7,25 +7,32 @@
PORTNAME= tucan
PORTVERSION= 0.3.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://forja.rediris.es/frs/download.php/1470/ \
http://build-tucan-doc.googlecode.com/files/
MAINTAINER= gustau.perez@gmail.com
-COMMENT= Give us the links, we'll cook the meal!
+COMMENT= Tucan Manager aids file-sharing with 1-click hosters
RUN_DEPENDS= ${LOCALBASE}/bin/pilconvert.py:${PORTSDIR}/graphics/py-imaging \
${LOCALBASE}/bin/cntraining:${PORTSDIR}/graphics/tesseract/
NO_BUILD= yes
USE_GNOME= pygtk2 librsvg2
-USE_PYTHON= yes
+USE_PYTHON= 2.5+
MANCOMPRESSED= yes
MAN1= tucan.1
USE_GETTEXT= yes
+post-patch:
+ ${REINPLACE_CMD} -Ee 's|#! /usr/bin/env python|#! ${PYTHON_CMD}|' ${WRKSRC}/tucan.py
+
+# remove .orig leftovers from files/patch-*
+pre-install:
+ ${RM} ${WRKSRC}/core/*.orig
+
do-install:
${MKDIR} ${PREFIX}/bin/
${MKDIR} ${PREFIX}/share/pixmaps/
diff --git a/net/tucan/files/patch-core__service_config.py b/net/tucan/files/patch-core__service_config.py
new file mode 100644
index 000000000000..28ed918b3ad0
--- /dev/null
+++ b/net/tucan/files/patch-core__service_config.py
@@ -0,0 +1,19 @@
+--- ./core/service_config.py.orig 2009-10-07 01:02:28.000000000 +0200
++++ ./core/service_config.py 2011-05-22 19:41:52.000000000 +0200
+@@ -18,7 +18,7 @@
+ ## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ ###############################################################################
+
+-import os
++import os, stat
+ import pickle
+ import base64
+ import logging
+@@ -157,6 +157,7 @@
+
+ def save(self):
+ """"""
++ os.chmod(self.path + CONF, stat.S_IRUSR|stat.S_IWUSR)
+ f = open(self.path + CONF, "w")
+ self.write(f)
+ f.close()
diff --git a/net/tucan/pkg-descr b/net/tucan/pkg-descr
index 35120092067d..61451e7f3dde 100644
--- a/net/tucan/pkg-descr
+++ b/net/tucan/pkg-descr
@@ -1,4 +1,11 @@
-Tucan Manager is a free file sharing application designed for 1-Click
-Hosters. Fast and lightweight.
+Supporting the main Hosters like RapidShare or MegaUpload, Tucan
+brings a new experience to users discouraged by other file sharing
+methods as p2p.
+
+Tesseract OCR engine in combination with PIL library, grant
+Tucan the ability to solve any captcha whitout user action.
+
+Tucan also manages waits between downloads and interchangeable
+links seamlessly, relieving the user from this nuisance.
WWW: http://www.tucaneando.com