aboutsummaryrefslogtreecommitdiffstats
path: root/net/tund
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-06 03:02:59 +0800
committermiwi <miwi@FreeBSD.org>2007-01-06 03:02:59 +0800
commitdb9a731b6dd9ecdbe8b549451e32dbaa70c2035f (patch)
tree906e94139f0d5cbe03e1526c92fb249bf901071b /net/tund
parent78d2c6863fc7dda4c202ddc195728f4b8c059b9f (diff)
downloadfreebsd-ports-gnome-db9a731b6dd9ecdbe8b549451e32dbaa70c2035f.tar.gz
freebsd-ports-gnome-db9a731b6dd9ecdbe8b549451e32dbaa70c2035f.tar.zst
freebsd-ports-gnome-db9a731b6dd9ecdbe8b549451e32dbaa70c2035f.zip
2007-01-04 net/tund: distfile disappeared and has no homepage
2007-01-04 net/xbms: distfile and homepage disappeared 2007-01-03 print/bibcard: distfile and homepage disappeared
Diffstat (limited to 'net/tund')
-rw-r--r--net/tund/Makefile30
-rw-r--r--net/tund/distinfo3
-rw-r--r--net/tund/files/patch-aa34
-rw-r--r--net/tund/files/patch-ab86
-rw-r--r--net/tund/pkg-descr8
-rw-r--r--net/tund/pkg-plist6
6 files changed, 0 insertions, 167 deletions
diff --git a/net/tund/Makefile b/net/tund/Makefile
deleted file mode 100644
index 449974eef04c..000000000000
--- a/net/tund/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: tund
-# Date created: 20 July 1999
-# Whom: Sergey Kosyakov <ks@itp.ac.ru>
-#
-# $FreeBSD$
-#
-
-PORTNAME= tund
-PORTVERSION= 0.20
-CATEGORIES= net
-MASTER_SITES= ftp://ftp.cemu.ru/pub/distfiles/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= IP over UDP tunnel with encryption
-
-DEPRECATED= distfile disappeared and has no homepage
-EXPIRATION_DATE= 2007-01-04
-
-USE_OPENSSL= YES
-
-MAN8= tund.8
-MANCOMPRESSED= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= "Does not build on ${ARCH}"
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/net/tund/distinfo b/net/tund/distinfo
deleted file mode 100644
index 154e8cca3dbe..000000000000
--- a/net/tund/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (tund-0.20.tar.gz) = b5027241938f60033c103b3b44769bbf
-SHA256 (tund-0.20.tar.gz) = dc0813c3b0e220dbab4fd6a5b60d0bcaff20e9157ab4ec2e252e8deb2e63aeab
-SIZE (tund-0.20.tar.gz) = 13876
diff --git a/net/tund/files/patch-aa b/net/tund/files/patch-aa
deleted file mode 100644
index 6fb7b28144a1..000000000000
--- a/net/tund/files/patch-aa
+++ /dev/null
@@ -1,34 +0,0 @@
---- Makefile.orig Tue Aug 24 03:48:00 1999
-+++ Makefile Tue Mar 7 22:35:21 2000
-@@ -1,22 +1,24 @@
-
- RSA_KEY_LENGTH = 1024
-
--CFLAGS = -g -DDEBUG
-+CFLAGS ?= -O2
-+CFLAGS += -g -DDEBUG $(OPENSSL_CFLAGS)
- # CFLAGS = -O6 -mpentium
--CC = cc $(CFLAGS)
--INC = -I/usr/local/include
--LIB = -L/usr/local/lib
-+CC ?= cc
-+CC += $(CFLAGS)
-+INC = -I$(OPENSSLINC)
-+LIB = -L$(OPENSSLLIB)
-
- all: rsa_kg pkey_gen tund keygen
-
- rsa_kg: rsa_kg.c tund.h
-- $(CC) -o rsa_kg rsa_kg.c $(INC) $(LIB) -lcrypto
-+ $(CC) -o rsa_kg rsa_kg.c $(INC) $(LIB) -lcrypto $(EXTRA_SSL_LIBS)
-
- pkey_gen: pkey_gen.c tund.h
-- $(CC) -o pkey_gen pkey_gen.c $(INC) $(LIB) -lcrypto
-+ $(CC) -o pkey_gen pkey_gen.c $(INC) $(LIB) -lcrypto $(EXTRA_SSL_LIBS)
-
- tund: main.o tund.o secur.o scb.o utils.o md5.o alarm.o cipher.o search.o
-- $(CC) -static -o tund main.o tund.o secur.o scb.o utils.o md5.o alarm.o cipher.o search.o $(LIB) -lmd -lcrypto
-+ $(CC) -o tund main.o tund.o secur.o scb.o utils.o md5.o alarm.o cipher.o search.o $(LIB) -lmd -lcrypto $(EXTRA_SSL_LIBS)
-
- main.o: main.c tund.h
- $(CC) -c main.c $(INC)
diff --git a/net/tund/files/patch-ab b/net/tund/files/patch-ab
deleted file mode 100644
index 8882676cea57..000000000000
--- a/net/tund/files/patch-ab
+++ /dev/null
@@ -1,86 +0,0 @@
---- cipher.c.orig Sat Feb 5 21:35:24 2000
-+++ cipher.c Sat Feb 5 21:38:51 2000
-@@ -1,7 +1,9 @@
- #include <stdlib.h>
- #include "tund.h"
- #include <openssl/blowfish.h>
-+#ifndef NO_IDEA
- #include <openssl/idea.h>
-+#endif
- #include <openssl/rc5.h>
-
-
-@@ -27,7 +29,9 @@
- {
- Tunnel *tun;
- BF_KEY *bf_key;
-+#ifndef NO_IDEA
- IDEA_KEY_SCHEDULE *idea_key1,*idea_key2;
-+#endif
- RC5_32_KEY *rc5_key;
- void *key;
- unsigned char *data;
-@@ -56,6 +60,7 @@
- BF_set_key(bf_key,16,data);
- key=bf_key;
- break;
-+#ifndef NO_IDEA
- case TUN_CIPHER_IDEA: idea_key1=must_malloc(sizeof(IDEA_KEY_SCHEDULE));
- idea_set_encrypt_key(data,idea_key1);
- if(remote)
-@@ -67,6 +72,7 @@
- }
- key=idea_key1;
- break;
-+#endif
- case TUN_CIPHER_RC5:rc5_key=must_malloc(sizeof(RC5_32_KEY));
- RC5_32_set_key(rc5_key,16,data,RC5_8_ROUNDS);
- key=rc5_key;
-@@ -93,7 +99,9 @@
- Tunnel *tun=(Tunnel*)stun->buf[tun_ind];
- int cipher;
- BF_KEY *bf_key;
-+#ifndef NO_IDEA
- IDEA_KEY_SCHEDULE *idea_key;
-+#endif
- RC5_32_KEY *rc5_key;
- int length;
-
-@@ -106,11 +114,13 @@
- bcopy(ivec_ini,iv_buf,8);
- BF_cbc_encrypt(in,out,length,bf_key,iv_buf,BF_ENCRYPT);
- return length;
-+#ifndef NO_IDEA
- case TUN_CIPHER_IDEA:idea_key=tun->localCipherKey;
- bcopy(ivec_ini,iv_buf,8);
- idea_cbc_encrypt(in,out,length,idea_key,
- iv_buf,IDEA_ENCRYPT);
- return length;
-+#endif
- case TUN_CIPHER_RC5:rc5_key=tun->localCipherKey;
- bcopy(ivec_ini,iv_buf,8);
- RC5_32_cbc_encrypt(in,out,length,rc5_key,
-@@ -129,7 +139,9 @@
- Tunnel *tun=(Tunnel*)stun->buf[tun_ind];
- int cipher;
- BF_KEY *bf_key;
-+#ifndef NO_IDEA
- IDEA_KEY_SCHEDULE *idea_key;
-+#endif
- RC5_32_KEY *rc5_key;
- int length;
-
-@@ -142,11 +154,13 @@
- bcopy(ivec_ini,iv_buf,8);
- BF_cbc_encrypt(in,out,length,bf_key,iv_buf,BF_DECRYPT);
- break;
-+#ifndef NO_IDEA
- case TUN_CIPHER_IDEA:idea_key=tun->remoteCipherKey;
- bcopy(ivec_ini,iv_buf,8);
- idea_cbc_encrypt(in,out,length,idea_key,
- iv_buf,IDEA_DECRYPT);
- break;
-+#endif
- case TUN_CIPHER_RC5:rc5_key=tun->remoteCipherKey;
- bcopy(ivec_ini,iv_buf,8);
- RC5_32_cbc_encrypt(in,out,length,rc5_key,
diff --git a/net/tund/pkg-descr b/net/tund/pkg-descr
deleted file mode 100644
index 1c76416a05c5..000000000000
--- a/net/tund/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-TUND allows to organize IP over IP tunnel (IP packets are incapsulated
-into UDP one). It works together with FreeBSD ipfw(8). Can be used
-for tunneling private networks behinf NATD. Supports encryption with various
-ciphers, RSA authentication, multiple and parallel tunnels (up to 65534
-tunnels) with single UDP port.
-
-Sergey Kosyakov
-ks@itp.ac.ru
diff --git a/net/tund/pkg-plist b/net/tund/pkg-plist
deleted file mode 100644
index cd486a1f5c34..000000000000
--- a/net/tund/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-etc/tund.conf
-etc/tund.hosts.key
-etc/tund.rsa.key
-etc/tund.seed.rng
-sbin/pkey_gen
-sbin/tund