aboutsummaryrefslogtreecommitdiffstats
path: root/net/udt
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2014-02-12 06:07:04 +0800
committermi <mi@FreeBSD.org>2014-02-12 06:07:04 +0800
commit0731a6a7452bd6fe68c87516806e8595dc863687 (patch)
tree7f078e61b0cda4317ff40aadc744065e65705667 /net/udt
parent68ab44696cd5f376a3792df57f5a3f8f18cf6426 (diff)
downloadfreebsd-ports-gnome-0731a6a7452bd6fe68c87516806e8595dc863687.tar.gz
freebsd-ports-gnome-0731a6a7452bd6fe68c87516806e8595dc863687.tar.zst
freebsd-ports-gnome-0731a6a7452bd6fe68c87516806e8595dc863687.zip
Relax the compiler warning flags slightly to ensure successful builds
with clang++ (on 10.x and -current). Notified by: pointyhat
Diffstat (limited to 'net/udt')
-rw-r--r--net/udt/files/BSDmakefile6
-rw-r--r--net/udt/files/patch-md53
2 files changed, 5 insertions, 4 deletions
diff --git a/net/udt/files/BSDmakefile b/net/udt/files/BSDmakefile
index 650073e2dac6..1ebebc00aa70 100644
--- a/net/udt/files/BSDmakefile
+++ b/net/udt/files/BSDmakefile
@@ -12,9 +12,9 @@ SRCS= common.cpp window.cpp list.cpp buffer.cpp packet.cpp channel.cpp \
queue.cpp ccc.cpp cache.cpp core.cpp epoll.cpp api.cpp
CXXFLAGS+= -D${MACHINE_ARCH:U:S/I386/IA32/:S/SPARC64/SPARC/} -DBSD
-CXXFLAGS+= -Wsystem-headers -Werror -Wall -W \
+CXXFLAGS+= -Wno-system-headers -Wall -W \
-Wpointer-arith -Wreturn-type \
- -Wwrite-strings -Wswitch -Wcast-align \
- -Wunused-parameter
+ -Wwrite-strings -Wswitch -Wno-cast-align \
+ -Wunused-parameter -Werror
.include <bsd.lib.mk>
diff --git a/net/udt/files/patch-md5 b/net/udt/files/patch-md5
index cd97a28e68d8..639c2a285784 100644
--- a/net/udt/files/patch-md5
+++ b/net/udt/files/patch-md5
@@ -53,10 +53,11 @@ avoid a strlen().
}
--- src/core.cpp 2013-02-20 11:35:26.000000000 -0500
+++ src/core.cpp 2013-02-26 18:49:00.000000000 -0500
-@@ -40,4 +40,5 @@
+@@ -40,4 +40,6 @@
#ifndef WIN32
+ #include <err.h>
++ #include <stdint.h>
#include <unistd.h>
#include <netdb.h>
@@ -2460,12 +2461,28 @@