aboutsummaryrefslogtreecommitdiffstats
path: root/net/ulxmlrpcpp
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-04-20 13:36:39 +0800
committersem <sem@FreeBSD.org>2006-04-20 13:36:39 +0800
commit74b74bd77d3a4b5882c0d06ee0e93e8352f07e62 (patch)
tree8735a445fe9c8143eec9e9fdcca62b46fa9c5240 /net/ulxmlrpcpp
parentc6900ad81b8161d49830c2ea03a066f321380893 (diff)
downloadfreebsd-ports-gnome-74b74bd77d3a4b5882c0d06ee0e93e8352f07e62.tar.gz
freebsd-ports-gnome-74b74bd77d3a4b5882c0d06ee0e93e8352f07e62.tar.zst
freebsd-ports-gnome-74b74bd77d3a4b5882c0d06ee0e93e8352f07e62.zip
- Update to version 1.5.0
PR: ports/96008 Submitted by: Ports Fury
Diffstat (limited to 'net/ulxmlrpcpp')
-rw-r--r--net/ulxmlrpcpp/Makefile24
-rw-r--r--net/ulxmlrpcpp/distinfo6
-rw-r--r--net/ulxmlrpcpp/files/patch-config:ltmain.sh15
-rw-r--r--net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp11
-rw-r--r--net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxr_dispatcher.h11
-rw-r--r--net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_http_protorol.cpp38
-rw-r--r--net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_tcpip_connection.cpp11
-rw-r--r--net/ulxmlrpcpp/pkg-plist79
8 files changed, 110 insertions, 85 deletions
diff --git a/net/ulxmlrpcpp/Makefile b/net/ulxmlrpcpp/Makefile
index 094446f26282..26733ffd01e2 100644
--- a/net/ulxmlrpcpp/Makefile
+++ b/net/ulxmlrpcpp/Makefile
@@ -7,28 +7,32 @@
#
PORTNAME= ulxmlrpcpp
-PORTVERSION= 1.4.6
-PORTREVISION= 1
+PORTVERSION= 1.5.0
CATEGORIES= net devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-#DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E:S/b/beta/}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
-COMMENT= A ultra lightweight xml-rpc library written in C++
+COMMENT= An ultra lightweight xml-rpc library written in C++
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
USE_BZIP2= yes
+USE_GNOME= gnomehack gnometarget
USE_ICONV= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-doxygen
+USE_OPENSSL= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
post-patch:
- @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s| docs | |g' ${WRKSRC}/ulxmlrpcpp/Makefile.in
.include <bsd.port.mk>
diff --git a/net/ulxmlrpcpp/distinfo b/net/ulxmlrpcpp/distinfo
index 626b730b40af..d8645d5db017 100644
--- a/net/ulxmlrpcpp/distinfo
+++ b/net/ulxmlrpcpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (ulxmlrpcpp-1.4.6.tar.bz2) = 3d47450cd984d83b62f8ea3822d81e3e
-SHA256 (ulxmlrpcpp-1.4.6.tar.bz2) = 42c1c2eb9956835966a7719e6a919c6d66107e3fc8ea101d98fbe5c9c70b22b4
-SIZE (ulxmlrpcpp-1.4.6.tar.bz2) = 345696
+MD5 (ulxmlrpcpp-1.5.0-src.tar.bz2) = 8393c7db5b9209f0ee8de2709661579b
+SHA256 (ulxmlrpcpp-1.5.0-src.tar.bz2) = 542875a7304e2b016f84c075cbb140f5a1cc5d7692db5310b49c7acf89cd5521
+SIZE (ulxmlrpcpp-1.5.0-src.tar.bz2) = 545704
diff --git a/net/ulxmlrpcpp/files/patch-config:ltmain.sh b/net/ulxmlrpcpp/files/patch-config:ltmain.sh
deleted file mode 100644
index 599d50bf4bfe..000000000000
--- a/net/ulxmlrpcpp/files/patch-config:ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/ltmain.sh.orig Sun Dec 8 16:53:29 2002
-+++ config/ltmain.sh Wed Dec 10 11:43:13 2003
-@@ -4232,10 +4232,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp
deleted file mode 100644
index 21108c0bd170..000000000000
--- a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ulxmlrpcpp/ulxmlrpcpp.cpp.orig Thu Nov 27 02:44:22 2003
-+++ ulxmlrpcpp/ulxmlrpcpp.cpp Wed Dec 10 11:34:49 2003
-@@ -742,7 +742,7 @@
- {
- size_t outbytes = sizeof(buffer);
- char *outbuf = buffer;
-- char *inbuf = const_cast<char*>(val.data())+in_offset;
-+ const char *inbuf = const_cast<char*>(val.data())+in_offset;
- size_t inbytes = val.length()-in_offset;
- #if defined(__SUN__) || defined(__CYGWIN__)
- if ((int)iconv(con, &(const char*)inbuf, &inbytes, &outbuf, &outbytes) < 0)
diff --git a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxr_dispatcher.h b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxr_dispatcher.h
deleted file mode 100644
index b9c051c26075..000000000000
--- a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxr_dispatcher.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ulxmlrpcpp/ulxr_dispatcher.h.orig Fri Sep 3 17:06:46 2004
-+++ ulxmlrpcpp/ulxr_dispatcher.h Fri Sep 3 17:06:57 2004
-@@ -108,8 +108,6 @@
-
- typedef hidden::MethodWrapperBase* DynamicMethodCall_t; // call Wrappers call();
-
-- struct MethodCallDescriptor;
--
- enum CallType { CallNone,
- CallSystem,
- CallStatic,
diff --git a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_http_protorol.cpp b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_http_protorol.cpp
new file mode 100644
index 000000000000..f7b67187122c
--- /dev/null
+++ b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_http_protorol.cpp
@@ -0,0 +1,38 @@
+--- ulxmlrpcpp/ulxr_http_protocol.cpp.orig Sat Mar 4 03:40:46 2006
++++ ulxmlrpcpp/ulxr_http_protocol.cpp Mon Apr 17 02:00:48 2006
+@@ -153,7 +153,7 @@
+ pimpl->userTempFields.clear();
+ pimpl->bAcceptcookies = false;
+ pimpl->bChunkedEncoding = false;
+- pimpl->chunk_data.clear();
++ pimpl->chunk_data.erase();
+ pimpl->chunk_size = 0;
+ pimpl->chunk_body_skip = 0;
+ setChunkedTransfer(false);
+@@ -168,7 +168,7 @@
+ pimpl->headerprops.clear();
+ pimpl->cookies.clear();
+ pimpl->bChunkedEncoding = false;
+- pimpl->chunk_data.clear();
++ pimpl->chunk_data.erase();
+ pimpl->chunk_size = 0;
+ pimpl->chunk_body_skip = 0;
+ pimpl->chunk_terminated = false;
+@@ -444,7 +444,7 @@
+ len--;
+ if (--pimpl->chunk_body_skip <= 0)
+ {
+- pimpl->chunk_data.clear();
++ pimpl->chunk_data.erase();
+ setConnectionState(State(ConnChunkHeader));
+ }
+ break;
+@@ -523,7 +523,7 @@
+ ULXR_TRACE(ULXR_PCHAR("have chunked transfer encoding"));
+ pimpl->bChunkedEncoding = true;
+ pimpl->chunk_size = 0;
+- pimpl->chunk_data.clear();
++ pimpl->chunk_data.erase();
+ }
+ }
+
diff --git a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_tcpip_connection.cpp b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_tcpip_connection.cpp
new file mode 100644
index 000000000000..b40456cfd53f
--- /dev/null
+++ b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp__ulxr_tcpip_connection.cpp
@@ -0,0 +1,11 @@
+--- ulxmlrpcpp/ulxr_tcpip_connection.cpp.orig Sun Apr 16 04:15:21 2006
++++ ulxmlrpcpp/ulxr_tcpip_connection.cpp Mon Apr 17 01:39:52 2006
+@@ -45,6 +45,8 @@
+ #endif
+
+ #ifdef __unix__
++#include <sys/time.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/tcp.h>
+ #endif
diff --git a/net/ulxmlrpcpp/pkg-plist b/net/ulxmlrpcpp/pkg-plist
index d4a15ce0d82f..c3f387a5d8cc 100644
--- a/net/ulxmlrpcpp/pkg-plist
+++ b/net/ulxmlrpcpp/pkg-plist
@@ -1,44 +1,53 @@
bin/introspect
bin/meerkat_client
-bin/sum_server
-bin/ulxrstubber
-include/ulxmlrpcpp.h
+include/ulxmlrpcpp/contrib/mprocess_rpc_server.h
+include/ulxmlrpcpp/contrib/ssl_connection.h
+include/ulxmlrpcpp/ulxmlrpcpp.h
+include/ulxmlrpcpp/ulxr_cached_resource.h
+include/ulxmlrpcpp/ulxr_call.h
+include/ulxmlrpcpp/ulxr_callparse.h
+include/ulxmlrpcpp/ulxr_callparse_base.h
+include/ulxmlrpcpp/ulxr_callparse_wb.h
include/ulxmlrpcpp/ulxr_config.h
-include/ulxr_call.h
-include/ulxr_callparse.h
-include/ulxr_callparse_base.h
-include/ulxr_callparse_wb.h
-include/ulxr_connection.h
-include/ulxr_dispatcher.h
-include/ulxr_except.h
-include/ulxr_expatwrap.h
-include/ulxr_htmlform_handler.h
-include/ulxr_http_client.h
-include/ulxr_http_protocol.h
-include/ulxr_http_server.h
-include/ulxr_mtrpc_server.h
-include/ulxr_mutex.h
-include/ulxr_protocol.h
-include/ulxr_requester.h
-include/ulxr_response.h
-include/ulxr_responseparse.h
-include/ulxr_responseparse_base.h
-include/ulxr_responseparse_wb.h
-include/ulxr_signature.h
-include/ulxr_ssl_connection.h
-include/ulxr_tcpip_connection.h
-include/ulxr_value.h
-include/ulxr_valueparse.h
-include/ulxr_valueparse_base.h
-include/ulxr_valueparse_wb.h
-include/ulxr_wbxmlparse.h
-include/ulxr_xmlparse.h
-include/ulxr_xmlparse_base.h
-@dirrm include/ulxmlrpcpp
+include/ulxmlrpcpp/ulxr_connection.h
+include/ulxmlrpcpp/ulxr_dispatcher.h
+include/ulxmlrpcpp/ulxr_except.h
+include/ulxmlrpcpp/ulxr_expatwrap.h
+include/ulxmlrpcpp/ulxr_file_resource.h
+include/ulxmlrpcpp/ulxr_htmlform_handler.h
+include/ulxmlrpcpp/ulxr_http_client.h
+include/ulxmlrpcpp/ulxr_http_protocol.h
+include/ulxmlrpcpp/ulxr_http_server.h
+include/ulxmlrpcpp/ulxr_mtrpc_server.h
+include/ulxmlrpcpp/ulxr_mutex.h
+include/ulxmlrpcpp/ulxr_protocol.h
+include/ulxmlrpcpp/ulxr_requester.h
+include/ulxmlrpcpp/ulxr_response.h
+include/ulxmlrpcpp/ulxr_responseparse.h
+include/ulxmlrpcpp/ulxr_responseparse_base.h
+include/ulxmlrpcpp/ulxr_responseparse_wb.h
+include/ulxmlrpcpp/ulxr_signature.h
+include/ulxmlrpcpp/ulxr_ssl_connection.h
+include/ulxmlrpcpp/ulxr_tcpip_connection.h
+include/ulxmlrpcpp/ulxr_value.h
+include/ulxmlrpcpp/ulxr_valueparse.h
+include/ulxmlrpcpp/ulxr_valueparse_base.h
+include/ulxmlrpcpp/ulxr_valueparse_wb.h
+include/ulxmlrpcpp/ulxr_virtual_resource.h
+include/ulxmlrpcpp/ulxr_wbxmlparse.h
+include/ulxmlrpcpp/ulxr_xmlparse.h
+include/ulxmlrpcpp/ulxr_xmlparse_base.h
lib/libulxmlrpcpp.a
+lib/libulxmlrpcpp.la
lib/libulxmlrpcpp.so
-lib/libulxmlrpcpp.so.10
+lib/libulxmlrpcpp.so.13
+lib/libulxmlrpcpp_contrib.a
+lib/libulxmlrpcpp_contrib.la
+lib/libulxmlrpcpp_contrib.so
+lib/libulxmlrpcpp_contrib.so.13
%%DATADIR%%/httpd/index.html
%%DATADIR%%/httpd/logo-ulxmlrpcpp.png
@dirrm %%DATADIR%%/httpd
@dirrm %%DATADIR%%
+@dirrm include/ulxmlrpcpp/contrib
+@dirrm include/ulxmlrpcpp