aboutsummaryrefslogtreecommitdiffstats
path: root/net/uplog
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-06-17 13:22:09 +0800
committerdaichi <daichi@FreeBSD.org>2003-06-17 13:22:09 +0800
commit3e3764984944d864a54f72c26f7059a961952588 (patch)
tree748f1f4dc825754bc9af13344f33fe67386995c4 /net/uplog
parentd1ff039b40431c3df4684ed14701711d6605b740 (diff)
downloadfreebsd-ports-gnome-3e3764984944d864a54f72c26f7059a961952588.tar.gz
freebsd-ports-gnome-3e3764984944d864a54f72c26f7059a961952588.tar.zst
freebsd-ports-gnome-3e3764984944d864a54f72c26f7059a961952588.zip
New port added, thanks!
Uplog is UDP based ping program with an "ASCII-graphical" log file. For more information: http://www.nerdlabs.org/projects/uplog.php PR: 53373 Submitted by: Kirill Ponomarew <ponomarew@oberon.net>
Diffstat (limited to 'net/uplog')
-rw-r--r--net/uplog/192.168.1.1011
-rw-r--r--net/uplog/192.168.1.1022
-rw-r--r--net/uplog/192.168.1.1091
-rw-r--r--net/uplog/Makefile36
-rw-r--r--net/uplog/distinfo1
-rw-r--r--net/uplog/pkg-descr10
-rw-r--r--net/uplog/pkg-plist3
7 files changed, 54 insertions, 0 deletions
diff --git a/net/uplog/192.168.1.101 b/net/uplog/192.168.1.101
new file mode 100644
index 000000000000..1b31f0d6ab6f
--- /dev/null
+++ b/net/uplog/192.168.1.101
@@ -0,0 +1 @@
+2003-06-17 14:18 ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
diff --git a/net/uplog/192.168.1.102 b/net/uplog/192.168.1.102
new file mode 100644
index 000000000000..77caf76fc84a
--- /dev/null
+++ b/net/uplog/192.168.1.102
@@ -0,0 +1,2 @@
+2003-06-17 14:18 ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
+2003-06-17 14:18 ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
diff --git a/net/uplog/192.168.1.109 b/net/uplog/192.168.1.109
new file mode 100644
index 000000000000..9be634d17ab9
--- /dev/null
+++ b/net/uplog/192.168.1.109
@@ -0,0 +1 @@
+2003-06-17 14:18 ...........................................................
diff --git a/net/uplog/Makefile b/net/uplog/Makefile
new file mode 100644
index 000000000000..9d10f5d1fb7e
--- /dev/null
+++ b/net/uplog/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: uplog
+# Date created: 16.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uplog
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.nerdlabs.org/downloads/${PORTNAME}/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= UDP-based ping programm
+
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|#include <malloc.h>||g' \
+ ${WRKSRC}/${PORTNAME}.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/uplog/distinfo b/net/uplog/distinfo
new file mode 100644
index 000000000000..78af9c1f5ede
--- /dev/null
+++ b/net/uplog/distinfo
@@ -0,0 +1 @@
+MD5 (uplog-0.1.tar.gz) = 3b4e9e0bcc76ca9648ef4846577ff13d
diff --git a/net/uplog/pkg-descr b/net/uplog/pkg-descr
new file mode 100644
index 000000000000..388d8a8363f8
--- /dev/null
+++ b/net/uplog/pkg-descr
@@ -0,0 +1,10 @@
+Uplog is an UDP-based ping program that gives an ASCII
+graphical log of packet loss. Once per second, it sends a UDP
+packet to the echo port of the target host and waits for a
+reply. If it gets a reply an X is written, otherwise a dot is
+written to the log file. If a packet with an incorrect sequence
+number arrives, a colon is written to the log file. By
+examining the log file, one can easily see when and how the
+packet losses occur.
+
+WWW: http://www.nerdlabs.org/projects/uplog.php
diff --git a/net/uplog/pkg-plist b/net/uplog/pkg-plist
new file mode 100644
index 000000000000..eaa78598ef43
--- /dev/null
+++ b/net/uplog/pkg-plist
@@ -0,0 +1,3 @@
+bin/uplog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%