aboutsummaryrefslogtreecommitdiffstats
path: root/net/v6eval
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-02-05 03:54:41 +0800
committerbeech <beech@FreeBSD.org>2008-02-05 03:54:41 +0800
commit0e4d6befd4ced3a3c10d26823223a2464276e770 (patch)
tree072cc643c10052be303df81887f99f03f0792dbe /net/v6eval
parent49cbcfa3f7bdc5791f530fc8ba8cafc413912890 (diff)
downloadfreebsd-ports-gnome-0e4d6befd4ced3a3c10d26823223a2464276e770.tar.gz
freebsd-ports-gnome-0e4d6befd4ced3a3c10d26823223a2464276e770.tar.zst
freebsd-ports-gnome-0e4d6befd4ced3a3c10d26823223a2464276e770.zip
- Fix man install
- Add patch to fix gcc-4.2 build problem on amd64 - Bump portrevision Reported by: pointyhat via pav
Diffstat (limited to 'net/v6eval')
-rw-r--r--net/v6eval/Makefile3
-rw-r--r--net/v6eval/files/patch-lib_Cm_BtObject.cc10
2 files changed, 12 insertions, 1 deletions
diff --git a/net/v6eval/Makefile b/net/v6eval/Makefile
index 014480b06a6c..39c7fa695e72 100644
--- a/net/v6eval/Makefile
+++ b/net/v6eval/Makefile
@@ -7,7 +7,7 @@
PORTNAME= v6eval
PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.tahi.org/release/v6eval/
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect \
USE_PERL5= yes
USE_OPENSSL= yes
+NOMANCOMPRESS= yes
MAN1PREFIX= ${PREFIX}/v6eval
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN1= pktctl.1.gz pktsend.1.gz
diff --git a/net/v6eval/files/patch-lib_Cm_BtObject.cc b/net/v6eval/files/patch-lib_Cm_BtObject.cc
new file mode 100644
index 000000000000..cc9c162c7b3d
--- /dev/null
+++ b/net/v6eval/files/patch-lib_Cm_BtObject.cc
@@ -0,0 +1,10 @@
+--- lib/Cm/BtObject.cc.orig 2001-10-11 20:56:13.000000000 -0800
++++ lib/Cm/BtObject.cc 2008-02-03 13:27:51.000000000 -0900
+@@ -47,6 +47,6 @@
+ BtObject::BtObject(const BtObject&) {}
+ BtObject::~BtObject() {}
+ uint32_t BtObject::hash() const {return 0;}
+-int BtObject::compare(const BtObject*p) const {return (int)this-(int)p;}
++int BtObject::compare(const BtObject*p) const {return (long)this-(long)p;}
+ bool BtObject::isEqual(const BtObject* v) const {
+ return compare(v)==0;}