aboutsummaryrefslogtreecommitdiffstats
path: root/net/vde2
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-01-29 01:50:03 +0800
committermiwi <miwi@FreeBSD.org>2012-01-29 01:50:03 +0800
commit8d4ea2b744918513ab785f4d78f844efcf6f04c2 (patch)
treeb55a2bf0a851d8b21f885d57e9560575fbb6c0c8 /net/vde2
parent79f47dea454c8f899a158c02addfb87e6923a301 (diff)
downloadfreebsd-ports-gnome-8d4ea2b744918513ab785f4d78f844efcf6f04c2.tar.gz
freebsd-ports-gnome-8d4ea2b744918513ab785f4d78f844efcf6f04c2.tar.zst
freebsd-ports-gnome-8d4ea2b744918513ab785f4d78f844efcf6f04c2.zip
- Update to version 2.3.2
PR: 164164 Submitted by: Ports Fury
Diffstat (limited to 'net/vde2')
-rw-r--r--net/vde2/Makefile21
-rw-r--r--net/vde2/distinfo4
-rw-r--r--net/vde2/files/patch-src__dpipe.c11
-rw-r--r--net/vde2/pkg-plist3
4 files changed, 35 insertions, 4 deletions
diff --git a/net/vde2/Makefile b/net/vde2/Makefile
index b858fec78a3b..0de66b0e4fd2 100644
--- a/net/vde2/Makefile
+++ b/net/vde2/Makefile
@@ -6,20 +6,25 @@
#
PORTNAME= vde2
-PORTVERSION= 2.3.1
+PORTVERSION= 2.3.2
CATEGORIES= net
MASTER_SITES= SF/vde/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= User-mode virtual ethernet infrastructure
+LICENSE= BSD GPLv2 LGPL21
+LICENSE_COMB= multi
+
+OPTIONS= PYTHON "Enable python bindings support" on
+
CONFLICTS= vde-[0-9]*
USE_GNOME= gnomehack
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_UNSAFE=yes
MLINKS= unixcmd.1 vdecmd.1 \
vdeq.1 vdeqemu.1 \
@@ -30,6 +35,18 @@ MAN1= dpipe.1 slirpvde.1 unixcmd.1 unixterm.1 \
vdeq.1 vdetaplib.1 vdeterm.1 wirefilter.1
MAN8= vde_tunctl.8
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_PYTHON)
+CONFIGURE_ARGS+=--disable-python
+PLIST_SUB+= PYTHON="@comment "
+.else
+USE_PYTHON= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_SUB+= PYTHON=""
+.endif
+
.include <bsd.port.pre.mk>
.if defined(BATCH) || defined(PACKAGE_BUILDING)
diff --git a/net/vde2/distinfo b/net/vde2/distinfo
index 15e9679d9a62..7c286f9aec77 100644
--- a/net/vde2/distinfo
+++ b/net/vde2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vde2-2.3.1.tar.gz) = 6778c4a302b8fa3d9e2664760c9cf0bed02384984cbc79f773c1b230916e79ed
-SIZE (vde2-2.3.1.tar.gz) = 698059
+SHA256 (vde2-2.3.2.tar.gz) = 22df546a63dac88320d35d61b7833bbbcbef13529ad009c7ce3c5cb32250af93
+SIZE (vde2-2.3.2.tar.gz) = 770257
diff --git a/net/vde2/files/patch-src__dpipe.c b/net/vde2/files/patch-src__dpipe.c
new file mode 100644
index 000000000000..9417cc0869b0
--- /dev/null
+++ b/net/vde2/files/patch-src__dpipe.c
@@ -0,0 +1,11 @@
+--- src/dpipe.c.orig 2011-11-24 01:41:18.000000000 +0900
++++ src/dpipe.c 2011-11-28 03:05:11.000000000 +0900
+@@ -201,7 +201,7 @@
+
+ if (daemonize != 0)
+ daemon(0,0);
+- else if (setpgrp() != 0) {
++ else if (setpgrp(0,getpid()) != 0) {
+ fprintf(stderr,"Err: cannot create pgrp\n");
+ exit(1);
+ }
diff --git a/net/vde2/pkg-plist b/net/vde2/pkg-plist
index b17cd06bc271..facff94a3cb5 100644
--- a/net/vde2/pkg-plist
+++ b/net/vde2/pkg-plist
@@ -42,6 +42,9 @@ lib/libvdesnmp.a
lib/libvdesnmp.la
lib/libvdesnmp.so
lib/libvdesnmp.so.0
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/VdePlug.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/vdeplug_python.la
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/vdeplug_python.so
lib/vde2/vde_l3/bfifo.la
lib/vde2/vde_l3/bfifo.so
lib/vde2/vde_l3/pfifo.la