aboutsummaryrefslogtreecommitdiffstats
path: root/net/versuch
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-21 19:41:58 +0800
committermiwi <miwi@FreeBSD.org>2008-01-21 19:41:58 +0800
commit5970d5a7ea266fecf39f45f5d2d5e98c175bfe62 (patch)
tree1f052eeec5ef44f037966575393beb055cb9d898 /net/versuch
parent49f5c53eb058bdb807bba7c96ddc75725c092f0a (diff)
downloadfreebsd-ports-gnome-5970d5a7ea266fecf39f45f5d2d5e98c175bfe62.tar.gz
freebsd-ports-gnome-5970d5a7ea266fecf39f45f5d2d5e98c175bfe62.tar.zst
freebsd-ports-gnome-5970d5a7ea266fecf39f45f5d2d5e98c175bfe62.zip
- Fix build with gcc4.2
PR: 119707 Submitted by: Philippe Audeoud <jadawin@tuxaco.net>
Diffstat (limited to 'net/versuch')
-rw-r--r--net/versuch/Makefile10
-rw-r--r--net/versuch/files/patch-aaa.h11
-rw-r--r--net/versuch/files/patch-utils.cxx12
3 files changed, 25 insertions, 8 deletions
diff --git a/net/versuch/Makefile b/net/versuch/Makefile
index f6c8764f2351..f3e2f6f4c83b 100644
--- a/net/versuch/Makefile
+++ b/net/versuch/Makefile
@@ -19,7 +19,7 @@ COMMENT= H323 voice&video proxy
LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib \
h323_r.1:${PORTSDIR}/net/openh323 \
- pcre++.0:${PORTSDIR}/devel/pcre++
+ pcre\\+\\+.0:${PORTSDIR}/devel/pcre++
WRKSRC= ${WRKDIR}/versuch
@@ -27,10 +27,4 @@ USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:261
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/versuch/files/patch-aaa.h b/net/versuch/files/patch-aaa.h
new file mode 100644
index 000000000000..b1a98161c137
--- /dev/null
+++ b/net/versuch/files/patch-aaa.h
@@ -0,0 +1,11 @@
+--- Aaa.h.orig 2008-01-15 13:56:51.000000000 +0000
++++ Aaa.h 2008-01-15 13:57:41.000000000 +0000
+@@ -95,7 +95,7 @@
+ class TCDR
+ {
+ public:
+- TCDR::TCDR() { DisconnectCause = 0; StartTime = 0; StopTime = 0; };
++ TCDR() { DisconnectCause = 0; StartTime = 0; StopTime = 0; };
+ unsigned int CallRef;
+ unsigned int StartTime, StopTime, IncOctets, OutOctets, RouteRetries;
+ int FastStart, Tunneling;
diff --git a/net/versuch/files/patch-utils.cxx b/net/versuch/files/patch-utils.cxx
new file mode 100644
index 000000000000..7c5440c30e95
--- /dev/null
+++ b/net/versuch/files/patch-utils.cxx
@@ -0,0 +1,12 @@
+--- Utils.cxx.orig 2008-01-15 16:01:46.000000000 +0000
++++ Utils.cxx 2008-01-15 16:02:07.000000000 +0000
+@@ -10,7 +10,8 @@
+ #include "Utils.h"
+
+ #include <fstream>
+-
++#include <assert.h>
++
+ void wtrim(string& str) {
+ const char* sp_chars = " \t\r\n";
+ unsigned int fst_notsp = str.find_first_not_of(sp_chars);