aboutsummaryrefslogtreecommitdiffstats
path: root/net/vino
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-11-19 19:49:04 +0800
committerkwm <kwm@FreeBSD.org>2014-11-19 19:49:04 +0800
commitbe884cd42990f2e755c2c06bc38c8042cb8b0325 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /net/vino
parent1c38992aaca771dc7aab7ae768e5753c6381ecd3 (diff)
downloadfreebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.tar.gz
freebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.tar.zst
freebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.zip
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Diffstat (limited to 'net/vino')
-rw-r--r--net/vino/Makefile38
-rw-r--r--net/vino/distinfo4
-rw-r--r--net/vino/files/patch-configure11
-rw-r--r--net/vino/files/patch-server_vino-http.c24
-rw-r--r--net/vino/pkg-plist53
5 files changed, 27 insertions, 103 deletions
diff --git a/net/vino/Makefile b/net/vino/Makefile
index 3e072de12fc1..924dad7f5f87 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -1,37 +1,39 @@
# Created by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
# $FreeBSD$
-# $MCom: ports/net/vino/Makefile,v 1.81 2010/09/27 13:51:24 kwm Exp $
+# $MCom: ports/trunk/net/vino/Makefile 19968 2014-10-16 07:29:56Z gusi $
PORTNAME= vino
-PORTVERSION= 2.32.2
-PORTREVISION= 7
+PORTVERSION= 3.14.0
CATEGORIES= net gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= VNC server that allows for remote access to your GNOME desktop
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib \
- libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
+ libavahi-glib.so:${PORTSDIR}/net/avahi-app
-USES= gettext gmake pkgconfig tar:bzip2
-USE_GNOME= gnomeprefix intlhack gnomehack gnomepanel
-USE_XORG= xtst
-GNOME_DESKTOP_VERSION=2
+USES= gettext gmake pathfix pkgconfig tar:xz
+USE_GNOME= gnomeprefix gtk30 intlhack
+USE_XORG= xdamage xfixes xtst
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --without-network-manager \
+ --disable-http-server
+CPPFLAGS+= -I${LOCALBASE}/include -Wno-format-nonliteral
LDFLAGS+= -L${LOCALBASE}/lib
+GLIB_SCHEMAS= org.gnome.Vino.enums.xml org.gnome.Vino.gschema.xml
-GCONF_SCHEMAS= vino-server.schemas
-
-.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
-CONFIGURE_ARGS+=--enable-libnotify=yes
-.else
-CONFIGURE_ARGS+=--enable-libnotify=no
-.endif
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= NOTIFY
+OPTIONS_DEFAULT=NOTIFY
+NOTIFY_LIBS_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+NOTIFY_CONFIGURE_WITH= libnotify
.include <bsd.port.mk>
diff --git a/net/vino/distinfo b/net/vino/distinfo
index 5c6f8b6d5698..347e60b2598f 100644
--- a/net/vino/distinfo
+++ b/net/vino/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/vino-2.32.2.tar.bz2) = 1260b1f7b647caff69db441dc13c992f843d9d75b9386ec07b724a5e30c6d4fa
-SIZE (gnome2/vino-2.32.2.tar.bz2) = 856440
+SHA256 (gnome3/vino-3.14.0.tar.xz) = 8faf864009e697e8652e4833150eaaba3da6c5a85f9f95886a5b76b00e5a9c1b
+SIZE (gnome3/vino-3.14.0.tar.xz) = 749784
diff --git a/net/vino/files/patch-configure b/net/vino/files/patch-configure
deleted file mode 100644
index 9d64aa9f6476..000000000000
--- a/net/vino/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2010-04-01 16:50:38.000000000 +0200
-+++ configure 2010-04-01 16:50:38.000000000 +0200
-@@ -15991,6 +15991,8 @@ if test "x$ac_cv_header_ifaddrs_h" = "xy
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-+ #include <sys/types.h>
-+ #include <sys/socket.h>
- #include <ifaddrs.h>
- #include <net/if.h>
-
diff --git a/net/vino/files/patch-server_vino-http.c b/net/vino/files/patch-server_vino-http.c
deleted file mode 100644
index d51f9588589a..000000000000
--- a/net/vino/files/patch-server_vino-http.c
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: server/vino-http.c
-diff -u -p server/vino-http.c.orig server/vino-http.c
---- server/vino-http.c.orig Tue Feb 27 19:47:35 2007
-+++ server/vino-http.c Sun Mar 25 20:56:41 2007
-@@ -595,6 +595,9 @@ vino_http_create_listening_socket (VinoH
- {
- #ifdef ENABLE_IPV6
- struct sockaddr_in6 saddr_in6;
-+#ifdef IPV6_V6ONLY
-+ int off = 0;
-+#endif
- #endif
- struct sockaddr_in saddr_in;
- struct sockaddr *saddr;
-@@ -621,6 +624,9 @@ vino_http_create_listening_socket (VinoH
-
- #ifdef ENABLE_IPV6
- sock = socket (AF_INET6, SOCK_STREAM, 0);
-+#ifdef IPV6_V6ONLY
-+ setsockopt(sock, IPPROTO_IPV6, IPV6_V6ONLY, (void *)&off, sizeof(off));
-+#endif
-
- memset (&saddr_in6, 0, sizeof (struct sockaddr_in6));
- saddr_in6.sin6_family = AF_INET6;
diff --git a/net/vino/pkg-plist b/net/vino/pkg-plist
index 294c4dc48b07..3f9db0b5a747 100644
--- a/net/vino/pkg-plist
+++ b/net/vino/pkg-plist
@@ -1,9 +1,8 @@
-bin/vino-passwd
-bin/vino-preferences
-etc/xdg/autostart/vino-server.desktop
libexec/vino-server
-share/applications/vino-preferences.desktop
+share/GConf/gsettings/org.gnome.Vino.convert
+share/applications/vino-server.desktop
share/dbus-1/services/org.freedesktop.Telepathy.Client.Vino.service
+share/locale/an/LC_MESSAGES/vino.mo
share/locale/ar/LC_MESSAGES/vino.mo
share/locale/as/LC_MESSAGES/vino.mo
share/locale/ast/LC_MESSAGES/vino.mo
@@ -44,6 +43,7 @@ share/locale/it/LC_MESSAGES/vino.mo
share/locale/ja/LC_MESSAGES/vino.mo
share/locale/ka/LC_MESSAGES/vino.mo
share/locale/kk/LC_MESSAGES/vino.mo
+share/locale/km/LC_MESSAGES/vino.mo
share/locale/kn/LC_MESSAGES/vino.mo
share/locale/ko/LC_MESSAGES/vino.mo
share/locale/ku/LC_MESSAGES/vino.mo
@@ -77,6 +77,7 @@ share/locale/sr@latin/LC_MESSAGES/vino.mo
share/locale/sv/LC_MESSAGES/vino.mo
share/locale/ta/LC_MESSAGES/vino.mo
share/locale/te/LC_MESSAGES/vino.mo
+share/locale/tg/LC_MESSAGES/vino.mo
share/locale/th/LC_MESSAGES/vino.mo
share/locale/tr/LC_MESSAGES/vino.mo
share/locale/ug/LC_MESSAGES/vino.mo
@@ -88,47 +89,3 @@ share/locale/zh_CN/LC_MESSAGES/vino.mo
share/locale/zh_HK/LC_MESSAGES/vino.mo
share/locale/zh_TW/LC_MESSAGES/vino.mo
share/telepathy/clients/Vino.client
-%%DATADIR%%/vino-preferences.ui
-%%DATADIR%%/vino-prompt.ui
-%%DATADIR%%/webservices
-@dirrm %%DATADIR%%
-@dirrmtry share/telepathy/clients
-@dirrmtry share/telepathy
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mai/LC_MESSAGES
-@dirrmtry share/locale/mai
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/kk/LC_MESSAGES
-@dirrmtry share/locale/kk
-@dirrmtry share/locale/en@shaw/LC_MESSAGES
-@dirrmtry share/locale/en@shaw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as