aboutsummaryrefslogtreecommitdiffstats
path: root/net/vnc
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2008-04-10 04:43:02 +0800
committeranders <anders@FreeBSD.org>2008-04-10 04:43:02 +0800
commita2d689ea5a575cad2859aa2573fcf5e416e1062e (patch)
tree877834c0505089f3b452f3ac8d10dbc96aaa1a68 /net/vnc
parent89cb16c6aea740069b3f18672688732fb2684f4a (diff)
downloadfreebsd-ports-gnome-a2d689ea5a575cad2859aa2573fcf5e416e1062e.tar.gz
freebsd-ports-gnome-a2d689ea5a575cad2859aa2573fcf5e416e1062e.tar.zst
freebsd-ports-gnome-a2d689ea5a575cad2859aa2573fcf5e416e1062e.zip
Make port build with GCC 4.
Lose USE_GCC dependency. Approved by: maintainer timeout
Diffstat (limited to 'net/vnc')
-rw-r--r--net/vnc/Makefile1
-rw-r--r--net/vnc/files/extra-patch-xc-config-util-printver.c10
-rw-r--r--net/vnc/files/patch-xc-config-util-printver.c10
3 files changed, 20 insertions, 1 deletions
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index ba4f5fa69ce5..3affcb5a1015 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -20,7 +20,6 @@ COMMENT= Display X and Win32 desktops on remote X/Win32/Java displays
GNU_CONFIGURE= yes
# The vnc supplied zlib seg. faults if compiled with -O
CONFIGURE_ARGS= --with-installed-zlib
-USE_GCC= 3.4
USE_XLIB= yes
USE_XPM= yes
WANT_PERL= yes
diff --git a/net/vnc/files/extra-patch-xc-config-util-printver.c b/net/vnc/files/extra-patch-xc-config-util-printver.c
new file mode 100644
index 000000000000..1b98eec89f32
--- /dev/null
+++ b/net/vnc/files/extra-patch-xc-config-util-printver.c
@@ -0,0 +1,10 @@
+--- xc/config/util/printver.c.orig 2003-02-26 10:21:33.000000000 +0100
++++ xc/config/util/printver.c 2008-03-16 10:07:56.000000000 +0100
+@@ -8,6 +8,7 @@
+ /* $XFree86: xc/config/util/printver.c,v 1.2 2003/02/26 09:21:33 dawes Exp $ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "xf86Version.h"
+ #include "xf86Date.h"
+
diff --git a/net/vnc/files/patch-xc-config-util-printver.c b/net/vnc/files/patch-xc-config-util-printver.c
new file mode 100644
index 000000000000..1b98eec89f32
--- /dev/null
+++ b/net/vnc/files/patch-xc-config-util-printver.c
@@ -0,0 +1,10 @@
+--- xc/config/util/printver.c.orig 2003-02-26 10:21:33.000000000 +0100
++++ xc/config/util/printver.c 2008-03-16 10:07:56.000000000 +0100
+@@ -8,6 +8,7 @@
+ /* $XFree86: xc/config/util/printver.c,v 1.2 2003/02/26 09:21:33 dawes Exp $ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "xf86Version.h"
+ #include "xf86Date.h"
+