aboutsummaryrefslogtreecommitdiffstats
path: root/net/vtun
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2016-09-20 11:40:45 +0800
committercy <cy@FreeBSD.org>2016-09-20 11:40:45 +0800
commitf9d3fae5299979bdfa567d48faf2654092ab3a8b (patch)
tree0fbf2b481cfc428afedb66d5bcb702012de9fb20 /net/vtun
parenta3b83195742d2cb2cf1c266c01194f32f250efa9 (diff)
downloadfreebsd-ports-gnome-f9d3fae5299979bdfa567d48faf2654092ab3a8b.tar.gz
freebsd-ports-gnome-f9d3fae5299979bdfa567d48faf2654092ab3a8b.tar.zst
freebsd-ports-gnome-f9d3fae5299979bdfa567d48faf2654092ab3a8b.zip
Document the previous -z and the new -e command line options.
Diffstat (limited to 'net/vtun')
-rw-r--r--net/vtun/Makefile2
-rw-r--r--net/vtun/files/patch-main.c18
-rw-r--r--net/vtun/files/patch-vtund.830
3 files changed, 48 insertions, 2 deletions
diff --git a/net/vtun/Makefile b/net/vtun/Makefile
index 4e2286051c6a..3451d6206f4c 100644
--- a/net/vtun/Makefile
+++ b/net/vtun/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vtun
PORTVERSION= 3.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= SF
diff --git a/net/vtun/files/patch-main.c b/net/vtun/files/patch-main.c
index 409d85e427f9..5b7748ec912c 100644
--- a/net/vtun/files/patch-main.c
+++ b/net/vtun/files/patch-main.c
@@ -1,5 +1,5 @@
--- main.c.orig 2013-07-07 13:31:22.000000000 -0700
-+++ main.c 2016-09-19 20:05:37.120740000 -0700
++++ main.c 2016-09-19 20:32:29.072400000 -0700
@@ -39,9 +39,9 @@
#include "lib.h"
#include "compat.h"
@@ -46,3 +46,19 @@
vtun_syslog(LOG_ERR,"Can't write PID file");
return;
}
+@@ -273,12 +284,12 @@
+ printf("Usage: \n");
+ printf(" Server:\n");
+ #ifdef HAVE_WORKING_FORK
+- printf("\tvtund <-s|-i> [-f file] [-P port] [-L local address]\n");
++ printf("\tvtund <-s|-i> [-f file] [-P port] [-L local address] [-e] [-z pid_file ]\n");
+ #else
+- printf("\tvtund <-i> [-f file] [-P port] [-L local address]\n");
++ printf("\tvtund <-i> [-f file] [-P port] [-L local address] [-e]\n");
+ #endif
+ printf(" Client:\n");
+ /* I don't think these work. I'm disabling the suggestion - bish 20050601*/
+ printf("\tvtund [-f file] " /* [-P port] [-L local address] */
+- "[-q] [-p] [-m] [-t timeout] <host profile> <server address>\n");
++ "[-q] [-p] [-m] [-t timeout] [-e] <host profile> <server address>\n");
+ }
diff --git a/net/vtun/files/patch-vtund.8 b/net/vtun/files/patch-vtund.8
new file mode 100644
index 000000000000..8912af8a74f9
--- /dev/null
+++ b/net/vtun/files/patch-vtund.8
@@ -0,0 +1,30 @@
+--- vtund.8.orig 2016-09-17 13:01:21.000000000 -0700
++++ vtund.8 2016-09-19 20:38:04.531515000 -0700
+@@ -48,6 +48,12 @@
+ [
+ .I -n
+ ]
++[
++.I -e
++]
++[
++.I -s pid_file
++]
+ <
+ .I session
+ >
+@@ -116,6 +122,14 @@
+ Default is 30 seconds. This options is equivalent to the 'timeout' option of
+ config file.
+ .TP
++.I -e
++Use vtun-v6 extended mode.
++.TP
++.I -z pid_file
++Connect
++.I z pid_file
++The full pathname of the file containing the PID of the daemon in server mode.
++.TP
+ .I session
+ Session name from the config file.
+ .TP