aboutsummaryrefslogtreecommitdiffstats
path: root/net/vyqchat
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-20 15:48:02 +0800
committerpav <pav@FreeBSD.org>2005-09-20 15:48:02 +0800
commit205b8db8d2136a7dbe9f4ed01f7ac2d3dc87b244 (patch)
treea82d8a67a17c0cca95fa6377034f4b019f37a56e /net/vyqchat
parent740f14937291b3294fdb23b71c494cecd878220b (diff)
downloadfreebsd-ports-gnome-205b8db8d2136a7dbe9f4ed01f7ac2d3dc87b244.tar.gz
freebsd-ports-gnome-205b8db8d2136a7dbe9f4ed01f7ac2d3dc87b244.tar.zst
freebsd-ports-gnome-205b8db8d2136a7dbe9f4ed01f7ac2d3dc87b244.zip
- Fix compile on FreeBSD 4.X
- Fix libaudiofile dependency Submitted by: maintainer
Diffstat (limited to 'net/vyqchat')
-rw-r--r--net/vyqchat/Makefile9
-rw-r--r--net/vyqchat/files/patch-src-appwin.cpp11
-rw-r--r--net/vyqchat/files/patch-src-settings.cpp7
-rw-r--r--net/vyqchat/files/patch-src-settingsdlg.cpp11
-rw-r--r--net/vyqchat/files/patch-src-user.cpp13
-rw-r--r--net/vyqchat/files/patch-src-uuid.cpp9
-rw-r--r--net/vyqchat/files/patch-src-vcprotocol.cpp10
7 files changed, 58 insertions, 12 deletions
diff --git a/net/vyqchat/Makefile b/net/vyqchat/Makefile
index 5a04afc65c71..2b2767f852be 100644
--- a/net/vyqchat/Makefile
+++ b/net/vyqchat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vyqchat
PORTVERSION= 0.2.8
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://linux.bydg.org/~yogin/
@@ -32,10 +33,8 @@ LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=--without-libao
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile"
+.if !defined(WITHOUT_ARTS) || defined(WITH_LIBAO)
+LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/vyqchat/files/patch-src-appwin.cpp b/net/vyqchat/files/patch-src-appwin.cpp
new file mode 100644
index 000000000000..3f8f46b9c27b
--- /dev/null
+++ b/net/vyqchat/files/patch-src-appwin.cpp
@@ -0,0 +1,11 @@
+--- src/appwin.cpp Tue Jul 19 18:54:11 2005
++++ src/appwin.cpp Sun Sep 18 21:22:23 2005
+@@ -1265,7 +1265,7 @@
+ chattab->write(MAIN_CHANNEL, tmp, special_color);
+ if (settings->getScriptEnabled(EventInfo))
+ Scripting::executeInfoRequest(settings->getScriptFileName(EventInfo), QDateTime::currentDateTime(), from);
+- vc->vc_inforeqack(userslist->getIP(from), from, nick, settings->getHostname(), nick, settings->getIP().toString(), settings->getHideChannels() ? MAIN_CHANNEL: chattab->channelsList(), (status!=STATUS_NORMAL) ? autoanswer : QString(""));
++ vc->vc_inforeqack(userslist->getIP(from), from, nick, settings->getHostname(), nick, settings->getIP().toString(), settings->getHideChannels() ? QString(MAIN_CHANNEL): chattab->channelsList(), (status!=STATUS_NORMAL) ? autoanswer : QString(""));
+ }/*}}}*/
+
+ void MainWindow::on_vc_inforeqack(const QHostAddress &source, const QString &to, const QString &from, const QString &host, const QString &name, const QString &ip, const QString &channels, const QString &answer, const QString &computer, const QString &software, bool utf)/*{{{*/
diff --git a/net/vyqchat/files/patch-src-settings.cpp b/net/vyqchat/files/patch-src-settings.cpp
index 7d17134e1258..5b3871a5ab71 100644
--- a/net/vyqchat/files/patch-src-settings.cpp
+++ b/net/vyqchat/files/patch-src-settings.cpp
@@ -1,12 +1,13 @@
---- src/settings.cpp Mon Jul 18 21:54:08 2005
-+++ src/settings.cpp Sun Aug 7 15:59:58 2005
-@@ -14,8 +14,8 @@
+--- src/settings.cpp Mon Jul 18 21:54:08 2005
++++ src/settings.cpp Sun Sep 18 21:20:55 2005
+@@ -14,8 +14,9 @@
#include "settings.h"
#include <unistd.h>
#include <sys/ioctl.h>
-#include <net/if.h>
#include <sys/socket.h>
+#include <net/if.h>
++#include <netinet/in.h>
#include <sys/types.h>
#include <arpa/inet.h>
#include <stdlib.h>
diff --git a/net/vyqchat/files/patch-src-settingsdlg.cpp b/net/vyqchat/files/patch-src-settingsdlg.cpp
new file mode 100644
index 000000000000..132e0918884b
--- /dev/null
+++ b/net/vyqchat/files/patch-src-settingsdlg.cpp
@@ -0,0 +1,11 @@
+--- src/settingsdlg.cpp Mon Jul 18 21:54:08 2005
++++ src/settingsdlg.cpp Sun Sep 18 21:21:08 2005
+@@ -400,7 +400,7 @@
+ settings->setSoundType(static_cast<Sound::SoundType>(opt_snddev->id(opt_snddev->selected())));
+ sndcfgchanged = true;
+ }
+- settings->setEncodingName(l_enc->currentItem() ? l_enc->currentText() : "");
++ settings->setEncodingName(l_enc->currentItem() ? l_enc->currentText() : QString(""));
+ if (b_useutf->isChecked() != settings->getUseUTF())
+ settings->setUseUTF(b_useutf->isChecked());
+ settings->setHideChannels(b_hide->isChecked());
diff --git a/net/vyqchat/files/patch-src-user.cpp b/net/vyqchat/files/patch-src-user.cpp
new file mode 100644
index 000000000000..960845e644c6
--- /dev/null
+++ b/net/vyqchat/files/patch-src-user.cpp
@@ -0,0 +1,13 @@
+--- src/user.cpp Mon Jul 18 21:54:08 2005
++++ src/user.cpp Sun Sep 18 21:48:55 2005
+@@ -42,7 +42,9 @@
+
+ int User::height(const QListBox *lb) const/*{{{*/
+ {
+- return QMAX(lb->fontMetrics().height(), Icons::icon_user.pixmap(QIconSet::Small, true).height());
++ int h1 = lb->fontMetrics().height();
++ int h2 = Icons::icon_user.pixmap(QIconSet::Small, true).height();
++ return QMAX(h1, h2);
+ }/*}}}*/
+
+ int User::width(const QListBox *lb) const/*{{{*/
diff --git a/net/vyqchat/files/patch-src-uuid.cpp b/net/vyqchat/files/patch-src-uuid.cpp
index 10872796bcc0..40f63de8794e 100644
--- a/net/vyqchat/files/patch-src-uuid.cpp
+++ b/net/vyqchat/files/patch-src-uuid.cpp
@@ -1,15 +1,16 @@
---- src/uuid.cpp.orig Mon Jul 18 20:54:08 2005
-+++ src/uuid.cpp Sat Sep 17 23:03:48 2005
-@@ -12,7 +12,7 @@
+--- src/uuid.cpp Mon Jul 18 21:54:08 2005
++++ src/uuid.cpp Sun Sep 18 21:21:21 2005
+@@ -12,7 +12,8 @@
#include "uuid.h"
#include <qstring.h>
-#include <openssl/rand.h>
++#include <unistd.h>
+#include <fcntl.h>
UUID::UUID(): QByteArray(UUID_LEN)/*{{{*/
{
-@@ -35,7 +35,9 @@
+@@ -35,7 +36,9 @@
void UUID::generate()/*{{{*/
{
diff --git a/net/vyqchat/files/patch-src-vcprotocol.cpp b/net/vyqchat/files/patch-src-vcprotocol.cpp
new file mode 100644
index 000000000000..4080a2830c72
--- /dev/null
+++ b/net/vyqchat/files/patch-src-vcprotocol.cpp
@@ -0,0 +1,10 @@
+--- src/vcprotocol.cpp Mon Jul 18 21:58:26 2005
++++ src/vcprotocol.cpp Sun Sep 18 21:21:41 2005
+@@ -20,6 +20,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <stdlib.h>
++#include <time.h>
+ #include <iostream>
+
+ //