aboutsummaryrefslogtreecommitdiffstats
path: root/net/wais
diff options
context:
space:
mode:
authoradam <adam@FreeBSD.org>1994-09-24 04:14:57 +0800
committeradam <adam@FreeBSD.org>1994-09-24 04:14:57 +0800
commit8ea6202cca57405d3083f783d11cf91268cafb11 (patch)
treea70fe5934847b9c3185cbc36d6ea5d37b798d653 /net/wais
parent56fdf2cb8589fb01c3ea10b33d9cfe5d1e913741 (diff)
downloadfreebsd-ports-gnome-8ea6202cca57405d3083f783d11cf91268cafb11.tar.gz
freebsd-ports-gnome-8ea6202cca57405d3083f783d11cf91268cafb11.tar.zst
freebsd-ports-gnome-8ea6202cca57405d3083f783d11cf91268cafb11.zip
Initial import of freewais, needed for using WAIS indexing with GN.
Needs work for install and package. This is enough to build all the wais stuff and waisgn.
Diffstat (limited to 'net/wais')
-rw-r--r--net/wais/Makefile12
-rw-r--r--net/wais/files/patch-aa42
-rw-r--r--net/wais/pkg-comment1
-rw-r--r--net/wais/pkg-descr1
-rw-r--r--net/wais/pkg-plist1
5 files changed, 57 insertions, 0 deletions
diff --git a/net/wais/Makefile b/net/wais/Makefile
new file mode 100644
index 000000000000..4237d2a0fb81
--- /dev/null
+++ b/net/wais/Makefile
@@ -0,0 +1,12 @@
+# New ports collection makefile for: wais
+# Version required: 0.3
+# Date created: 20 Sep 1994
+# Whom: adam
+#
+# $Id: Makefile,v $
+#
+
+DISTNAME= freeWAIS-0.3
+MASTER_SITES= ftp://ftp.cnidr.org/pub/NIDR.tools/freewais
+
+.include <bsd.port.mk>
diff --git a/net/wais/files/patch-aa b/net/wais/files/patch-aa
new file mode 100644
index 000000000000..ea8913ccca9e
--- /dev/null
+++ b/net/wais/files/patch-aa
@@ -0,0 +1,42 @@
+*** Makefile Tue Mar 15 19:30:00 1994
+--- Makefile Fri Sep 16 21:56:22 1994
+***************
+*** 118,124 ****
+ # Use this version of CFLAGS for Linux with gcc
+ # CFLAGS = -O2 -ansi -m486 -fwritable-strings -I$(SUPDIR) -DTELL_USER -DUSG -DSECURE_SERVER -DRELEVANCE_FEEDBACK -DBOOLEANS -DPARTIALWORD -DLITERAL -DSOUND -DBIBDB -DLINUX
+
+! CFLAGS = -ansi -I$(SUPDIR) -DTELL_USER -DUSG -DSECURE_SERVER -DRELEVANCE_FEEDBACK -DBOOLEANS -DPARTIALWORD -DLITERAL -DSOUND -DBIBDB
+
+ # Solaris should use
+ #LIB = -ltcpip -lsocket -lnsl
+--- 118,124 ----
+ # Use this version of CFLAGS for Linux with gcc
+ # CFLAGS = -O2 -ansi -m486 -fwritable-strings -I$(SUPDIR) -DTELL_USER -DUSG -DSECURE_SERVER -DRELEVANCE_FEEDBACK -DBOOLEANS -DPARTIALWORD -DLITERAL -DSOUND -DBIBDB -DLINUX
+
+! CFLAGS = -ansi -I$(SUPDIR) -DTELL_USER -DUSG -DSECURE_SERVER -DRELEVANCE_FEEDBACK -DBOOLEANS -DPARTIALWORD -DLITERAL -DSOUND -DBIBDB -D__bsdi__
+
+ # Solaris should use
+ #LIB = -ltcpip -lsocket -lnsl
+***************
+*** 135,140 ****
+--- 135,142 ----
+
+ MAKE = make $(MFLAGS)
+
++ all: default
++
+ #default: config.h lib ir ui bin doc x tags
+ default: config.h lib ir ui bin x check
+ @echo "Welcome to WAIS"
+*** ir/irtfiles.c Wed Jan 19 16:10:32 1994
+--- ir/irtfiles.c Fri Sep 16 23:14:03 1994
+***************
+*** 75,80 ****
+--- 75,81 ----
+
+ #include <ctype.h>
+ #include <string.h>
++ #include <sys/types.h>
+ #include "panic.h"
+ #include "irdirent.h"
+ #include "irhash.h"
diff --git a/net/wais/pkg-comment b/net/wais/pkg-comment
new file mode 100644
index 000000000000..c6e815a4b854
--- /dev/null
+++ b/net/wais/pkg-comment
@@ -0,0 +1 @@
+freeWAIS 0.3 from CNIDR
diff --git a/net/wais/pkg-descr b/net/wais/pkg-descr
new file mode 100644
index 000000000000..59372c301599
--- /dev/null
+++ b/net/wais/pkg-descr
@@ -0,0 +1 @@
+FreeWAIS 0.3 from CNIDR
diff --git a/net/wais/pkg-plist b/net/wais/pkg-plist
new file mode 100644
index 000000000000..4a8ec730ee9e
--- /dev/null
+++ b/net/wais/pkg-plist
@@ -0,0 +1 @@
+@cwd /usr/local