aboutsummaryrefslogtreecommitdiffstats
path: root/net/wlan2eth
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-17 05:37:38 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-17 05:37:38 +0800
commit47092875c5854fdba96f94858b64aaf3d396090f (patch)
treee243fe43338158531900c8d447bee3137a1a7c81 /net/wlan2eth
parenta96d20e390511e0b3ddab0a8583287c843081a58 (diff)
downloadfreebsd-ports-gnome-47092875c5854fdba96f94858b64aaf3d396090f.tar.gz
freebsd-ports-gnome-47092875c5854fdba96f94858b64aaf3d396090f.tar.zst
freebsd-ports-gnome-47092875c5854fdba96f94858b64aaf3d396090f.zip
A simple tool to convert packet captures in 802.11 format to Ethernet format.
Lots of tools can only understand Ethernet link types, so I wrote this tool to convert captures to a format that they can understand. Note that this tool is really only useful for encrypted traffic. Specify a wireless packet capture as an input file, and the name of the desired Ethernet-format output file. Wlan2eth will only convert data frames to the output file, which will likely result in a significantly smaller output packet capture file. Note that wlan2eth will only convert unencrypted frames. WWW: http://www.willhackforsushi.com/?page_id=79 PR: ports/179095 Submitted by: nemysis (self) Approved by: wg/pawel (mentors)
Diffstat (limited to 'net/wlan2eth')
-rw-r--r--net/wlan2eth/Makefile32
-rw-r--r--net/wlan2eth/distinfo2
-rw-r--r--net/wlan2eth/files/pkg-message.in9
-rw-r--r--net/wlan2eth/pkg-descr11
4 files changed, 54 insertions, 0 deletions
diff --git a/net/wlan2eth/Makefile b/net/wlan2eth/Makefile
new file mode 100644
index 000000000000..b4dcc0257511
--- /dev/null
+++ b/net/wlan2eth/Makefile
@@ -0,0 +1,32 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wlan2eth
+PORTVERSION= 1.3
+CATEGORIES= net security
+MASTER_SITES= http://www.willhackforsushi.com/code/${PORTNAME}/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Convert packet captures in 802.11 format to Ethernet format
+
+LICENSE= GPLv2
+
+PORTDOCS= THANKS
+SUB_FILES= pkg-message
+
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CFLAGS =|CFLAGS ?=|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/wlan2eth/distinfo b/net/wlan2eth/distinfo
new file mode 100644
index 000000000000..1166397aa251
--- /dev/null
+++ b/net/wlan2eth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wlan2eth-1.3.tgz) = a6b9f4a9f0407f79e61571de73e800785d4047019d66b891a569ff75cc5fe774
+SIZE (wlan2eth-1.3.tgz) = 8242
diff --git a/net/wlan2eth/files/pkg-message.in b/net/wlan2eth/files/pkg-message.in
new file mode 100644
index 000000000000..e53216ead092
--- /dev/null
+++ b/net/wlan2eth/files/pkg-message.in
@@ -0,0 +1,9 @@
+===============================================================================
+
+wlan2eth has been installed.
+
+For more information about wlan2eth visit:
+
+http://www.willhackforsushi.com/?page_id=79
+
+===============================================================================
diff --git a/net/wlan2eth/pkg-descr b/net/wlan2eth/pkg-descr
new file mode 100644
index 000000000000..e834d8cc419a
--- /dev/null
+++ b/net/wlan2eth/pkg-descr
@@ -0,0 +1,11 @@
+A simple tool to convert packet captures in 802.11 format to Ethernet format.
+Lots of tools can only understand Ethernet link types, so I wrote this
+tool to convert captures to a format that they can understand.
+Note that this tool is really only useful for encrypted traffic.
+
+Specify a wireless packet capture as an input file, and the name of the
+desired Ethernet-format output file. Wlan2eth will only convert data frames
+to the output file, which will likely result in a significantly smaller output
+packet capture file. Note that wlan2eth will only convert unencrypted frames.
+
+WWW: http://www.willhackforsushi.com/?page_id=79