aboutsummaryrefslogtreecommitdiffstats
path: root/net/wmnd/Makefile
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2001-12-03 14:32:27 +0800
committerpat <pat@FreeBSD.org>2001-12-03 14:32:27 +0800
commit2ae13c6d88d55cf9da4ebc8c0d64ba7bc881190f (patch)
tree0121fe8eca3722dc2f4ebd421f461ad349a41c0a /net/wmnd/Makefile
parent2093a151dbfbd3690043c7c54963c15973f246e6 (diff)
downloadfreebsd-ports-gnome-2ae13c6d88d55cf9da4ebc8c0d64ba7bc881190f.tar.gz
freebsd-ports-gnome-2ae13c6d88d55cf9da4ebc8c0d64ba7bc881190f.tar.zst
freebsd-ports-gnome-2ae13c6d88d55cf9da4ebc8c0d64ba7bc881190f.zip
Add port net/wmnd a network monitor dockapp.
PR: 31690 Submitted by: Paolo Flag <flag@gufi.org> Reviewed by: petef
Diffstat (limited to 'net/wmnd/Makefile')
-rw-r--r--net/wmnd/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/wmnd/Makefile b/net/wmnd/Makefile
new file mode 100644
index 000000000000..335dd9fc4101
--- /dev/null
+++ b/net/wmnd/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: wmnd
+# Date created: 29 October 2001
+# Whom: Paolo Pisati <flag@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmnd
+PORTVERSION= 0.3.3
+CATEGORIES= net
+MASTER_SITES= http://www.wingeer.org/wmnd/pkg/
+DISTNAME= wmnd_${PORTVERSION}
+
+MAINTAINER= flag@gufi.org
+
+WRKSRC= ${WRKDIR}/wmnd
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+MAN1= wmnd.1
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+ @${INSTALL_PROGRAM} ${WRKSRC}/wmnd ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/man/wmnd.1 ${PREFIX}/man/man1
+ @${INSTALL_DATA} ${WRKSRC}/wmndrc \
+ ${PREFIX}/share/examples/${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+.for docs in CHANGELOGS DISPLAY HINTS README
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>