aboutsummaryrefslogtreecommitdiffstats
path: root/net/xmule
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-05-12 00:48:58 +0800
committerlioux <lioux@FreeBSD.org>2003-05-12 00:48:58 +0800
commitf2c23dc2274dc7d2c98e7994d78fd52cf7011d8a (patch)
treefd31d4e8662ac982726a39b21fa2adb9d130ad98 /net/xmule
parentcfe8279353a52db327236b42b3023fa3c4473653 (diff)
downloadfreebsd-ports-gnome-f2c23dc2274dc7d2c98e7994d78fd52cf7011d8a.tar.gz
freebsd-ports-gnome-f2c23dc2274dc7d2c98e7994d78fd52cf7011d8a.tar.zst
freebsd-ports-gnome-f2c23dc2274dc7d2c98e7994d78fd52cf7011d8a.zip
Comment out code when building in 5.x FreeBSD branch when using gcc
3.x. This code segment does not work with gcc 3.x. Is is responsible for a sanity check which will be improved in an upcoming LMule release. Obtained from: LMule Forums
Diffstat (limited to 'net/xmule')
-rw-r--r--net/xmule/files/patch-src::ED2KLink.cpp19
1 files changed, 19 insertions, 0 deletions
diff --git a/net/xmule/files/patch-src::ED2KLink.cpp b/net/xmule/files/patch-src::ED2KLink.cpp
new file mode 100644
index 000000000000..09e43be239b2
--- /dev/null
+++ b/net/xmule/files/patch-src::ED2KLink.cpp
@@ -0,0 +1,19 @@
+--- src/ED2KLink.cpp.orig Sun May 11 11:53:58 2003
++++ src/ED2KLink.cpp Sun May 11 11:57:00 2003
+@@ -216,6 +216,8 @@
+ pEnd = pCh;
+ while( *pEnd ) pEnd++; // make pEnd point to the terminating NULL
+ bAllowSources=true;
++// This code segment does not work with gcc 3.x. At least, under FreeBSD.
++#if defined(__FreeBSD__) && __FreeBSD_version >= 500035
+ // if there's an expiration date...
+ if( *pCh == _T('@') && (pEnd-pCh) > 7 )
+ {
+@@ -230,6 +232,7 @@
+ bAllowSources = ( expirationDate.Set(nYear,(wxDateTime::Month)nMonth,nDay,0,0,0,0) == 0l);
+ if (bAllowSources) bAllowSources=(wxDateTime::UNow() < expirationDate);
+ }
++#endif
+
+ // increment pCh to point to the first "ip:port" and check for sources
+ if ( bAllowSources && ++pCh < pEnd ) {
580f77769ef99c43b45768980b6'>Remove bogus spam I had in my cvs checkout and committed along with KDE.lofi2004-12-161-2/+0 * Update to KDE 3.3.2lofi2004-12-1413-18/+62 * Update to 4.13vs2004-12-133-7/+12 * Really build german versionvs2004-11-221-2/+2 * Fix missed path, remove USE_ZIP directive.mbr2004-11-221-2/+1 * Upgrade to staroffice 7 product update IV.mbr2004-11-222-9/+10 * Update to version 0.8markus2004-11-123-9/+15 * Update the English-language Netscape to 7.2. Add a security warningtrevor2004-11-091-0/+2 * Update to KDE 3.3.1lofi2004-11-0813-13/+130 * de-php_doc-de -> php_doc-deedwin2004-10-211-0/+1 * Update to KDE 3.3lofi2004-08-319-169/+301 * Factor out all but one of the build switches of the KDE main module portslofi2004-08-116-9/+9 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-101-1/+1 * Upgrade to Product Update 3.mbr2004-07-052-8/+9 * Establish a correct master-slave relationship betweenlinimon2004-06-241-1/+2 * - Remove empty files [1]pav2004-06-212-2/+1 * Update to version 3.2.3lofi2004-06-104-4/+84 * BROKEN: Unfetchablekris2004-06-091-0/+2 * - Fix MASTER_SITESkrion2004-06-081-2/+1 * Don't use Makefile.kde anymoremarkus2004-06-061-6/+3 * Upgrade to so-7-pp2 (product update 2)mbr2004-05-182-7/+8 * NO_LATEST_LINK=yesmbr2004-05-152-0/+2 * Oops. Forgot the language categories.lofi2004-05-076-9/+9 * Update to KDE 3.2.2lofi2004-04-204-40/+50 * Fix LATEST_LINK conflictsmaho2004-04-121-0/+1 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-052-2/+2 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * Update to 1.11: adds the possibility to change the font size in somelinimon2004-04-024-12/+13 * SIZEify (maintainer timeout)trevor2004-03-319-0/+22 * - Fix packagingpav2004-03-304-866/+60 * - SIZEifymarkus2004-03-291-0/+1 * Add SIZE.nectar2004-03-181-0/+1 * Add staroffice70kris2004-03-171-0/+1 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-141-1/+1 * Update to KDE 3.2.1 / QT 3.3.1lofi2004-03-109-4/+37 * - add SIZEdinoex2004-02-261-0/+1 * Change my email address.markus2004-02-241-1/+1 * BROKEN on 5.x: broken pkg-plistkris2004-02-091-1/+7 * Use PLIST_FILES (bento-tested, marcus-reviewed).trevor2004-02-062-1/+1 * Update to KDE 3.2.0lofi2004-02-0515-202/+1063 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-043-0/+3 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-045-10/+10 * Now gettext 0.12.1 is gettext-old.trevor2004-01-245-5/+5 * - fix PKGORIGINeik2004-01-231-1/+1 * - Update to 3.13pav2004-01-215-102/+334 * Fix Makefile comment in port.mbr2004-01-091-2/+2 * Add german port of staroffice7.0mbr2004-01-098-3680/+5317 * uncomment test lines. apologies.edwin2004-01-031-2/+2 * [NEW PORT] german/de-geonext: Interactive (dynamic) elementary Geometry Softwareedwin2004-01-035-0/+83 * - update to 0.95dinoex2003-12-292-2/+2 * Define USE_PERL5_BUILD, not erroneous USE_PERL.trevor2003-11-202-2/+2 * Define USE_PERL to make Perl available for (mostly deprecated)trevor2003-11-202-0/+2 * new German-language, i386 Linux binary port of Firebird Web browsertrevor2003-11-194-0/+26 * Fix COMMENT spellingeik2003-11-152-2/+2 * Fix COMMENT with an a-umlaut.nork2003-11-142-2/+2 * Add kheisereg, utility to search offline within the article databasearved2003-11-145-0/+85 * Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.trevor2003-11-131-1/+1 * OpenOffice -> OpenOffice.orgmaho2003-11-094-4/+4 * Language setting was wrong for german.maho2003-11-091-1/+1 * Add OpenOffice.org 1.1 for german.maho2003-11-093-0/+117 * Forgot to change Makefile s..maho2003-11-081-1/+1 * rename openoffice* to openoffice-1.0* accodingly (repo copy).maho2003-11-082-2/+2 * rename openoffice to openoffice-1.0 after repocopymaho2003-11-083-117/+1 * Per maintainer request, remove german/cheapcall. The mastersite haslinimon2003-11-035-56/+0 * Update German Linux manual pages to version 0.4wosch2003-10-292-8/+8 * Per distfile survey, chase new mastersite. Informed maintainer.linimon2003-10-293-4/+3 * utilize SITE_PERLijliao2003-10-241-1/+1 * Switch to tk84, bump PORTREVISION and tidy some whitespace.kris2003-10-191-8/+9 * update german/linux-eagle: 4.09r2 -> 4.11daichi2003-10-143-11/+42 * - use DOCSDIRdinoex2003-10-121-22/+22 * Translation update: fix checksum.will2003-09-222-2/+2 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-182-2/+2 * Update KDE to the latest official release, KDE 3.1.3lofi2003-07-294-10/+28 * Upgrade to use new patchset 112887-04.tarmbr2003-07-242-6/+6 * Fix distinfo for generated files: I mistakenly left "linux-" intrevor2003-07-061-1/+1 * Generate plist either statically or before do-install phase formarcus2003-07-061-3/+4 * Security fix: update to the latest versions: 7.1 for Americantrevor2003-07-038-599/+31 * Update to 0.9.4arved2003-06-133-3/+2 * Update to KDE 3.1.2lioux2003-05-206-10/+18 * Bring back from Attic: localized messages and documentation for kofficelioux2003-05-2013-0/+277 * Remove USE_GNOMENG.marcus2003-04-211-1/+0 * Add hyphenation dictionaries to the slave ports.mbr2003-04-092-0/+2 * Rejoice, for the long awaited upgrade to kde 3.1.1 is here!alane2003-04-064-10/+4 * - fix PLISTdinoex2003-04-052-1/+27 * Clear moonlight beckons.ade2003-03-0712-6/+6 * Remove pkg-comment from remaining master/slave port sets.ade2003-03-074-2/+2 * de-pkg-commentmbr2003-03-064-2/+4 * De-pkg-comment.wosch2003-03-056-3/+3 * - MAINTAINER in standard captiondinoex2003-03-051-1/+1 * -- Move pkg-comment into Makefilenectar2003-02-262-1/+1 * Do not fail if libXrender.so doesn't exist at all.mbr2003-02-221-0/+2 * De-pkg-comment.knu2003-02-218-4/+4 * De-pkg-comment.knu2003-02-212-1/+3 * - retire pkg-commentdinoex2003-02-211-1/+0 * De-pkg-comment.knu2003-02-212-1/+1 * - add COMMENTdinoex2003-02-211-0/+1 * Make some installation notes more clear. Inspired bymbr2003-02-202-7/+24 * Add ksteak, a KDE Frontend for steakarved2003-02-175-0/+80 * Add steak, another german <-> english dictionaryarved2003-02-158-0/+129 * Remove redundant category 'editors' in slave ports.mbr2003-02-132-2/+2 * Add staroffice6 wrapper script.mbr2003-02-051-0/+15 * Fetch the sunsolve patch for inofficial distsites, we have thembr2003-02-052-13/+25 * Upgrade kde-i18n to 3.1. Note that the following modules did not get awill2003-01-294-480/+1450 * Remove a file from pkg-plist.arved2003-01-271-1/+0 * Add the language define so the handbook is actually built formbr2003-01-252-0/+2 * Add a notice about possible crashes if a localized versionmbr2003-01-242-0/+24 * Add german pkg-message and pkg-comment.mbr2003-01-234-0/+156 * - make portlint happierdinoex2003-01-233-4/+8 * Remove obsolete linembr2003-01-231-1/+0 * Update StarOffice6.0 to patchlevel 3mbr2003-01-222-10/+21 * Add USE_LANG support for german port.mbr2003-01-222-0/+10 * Update WWW.arved2003-01-191-1/+1 * Add missing filekris2003-01-141-0/+1