aboutsummaryrefslogtreecommitdiffstats
path: root/net/xorp
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2012-10-02 13:32:23 +0800
committerkevlo <kevlo@FreeBSD.org>2012-10-02 13:32:23 +0800
commit549242c641e3010c0c6852fc81190e4f8fd55e9d (patch)
tree685a3bfe57a7948fc259b023fa888064f57b894c /net/xorp
parentd0e9cf785fd49a4ce038f4830cb25f07a8dce739 (diff)
downloadfreebsd-ports-gnome-549242c641e3010c0c6852fc81190e4f8fd55e9d.tar.gz
freebsd-ports-gnome-549242c641e3010c0c6852fc81190e4f8fd55e9d.tar.zst
freebsd-ports-gnome-549242c641e3010c0c6852fc81190e4f8fd55e9d.zip
Fix build on 10-CURRENT.
Diffstat (limited to 'net/xorp')
-rw-r--r--net/xorp/Makefile1
-rw-r--r--net/xorp/files/patch-libxorp-utility.h20
2 files changed, 21 insertions, 0 deletions
diff --git a/net/xorp/Makefile b/net/xorp/Makefile
index d551d5620dea..05728cfc89df 100644
--- a/net/xorp/Makefile
+++ b/net/xorp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xorp
PORTVERSION= 1.6
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.xorp.org/releases/${PORTVERSION}/ \
http://www2.xorp.org/releases/${PORTVERSION}/ \
diff --git a/net/xorp/files/patch-libxorp-utility.h b/net/xorp/files/patch-libxorp-utility.h
new file mode 100644
index 000000000000..76d633750b64
--- /dev/null
+++ b/net/xorp/files/patch-libxorp-utility.h
@@ -0,0 +1,20 @@
+--- libxorp/utility.h.orig 2012-10-01 17:45:19.000000000 +0800
++++ libxorp/utility.h 2012-10-01 17:47:34.000000000 +0800
+@@ -31,7 +31,7 @@
+ * Compile time assertion.
+ */
+ #ifndef static_assert
+-#define static_assert(a) switch (a) case 0: case (a):
++#define static_assert(a) ((void)sizeof(int[(a) ? 1 : -1]))
+ #endif /* static_assert */
+
+ /*
+@@ -42,7 +42,7 @@
+ #ifdef UNUSED
+ # undef UNUSED
+ #endif /* UNUSED */
+-#define UNUSED(var) static_assert(sizeof(var) != 0)
++#define UNUSED(var) ((void)var)
+
+ #ifdef __cplusplus
+ #define cstring(s) (s).str().c_str()