aboutsummaryrefslogtreecommitdiffstats
path: root/net/xwhois/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>1999-03-01 18:47:15 +0800
committerkris <kris@FreeBSD.org>1999-03-01 18:47:15 +0800
commit7f1964c4d8f32942c731b19cb84ffcfb0c02a651 (patch)
tree7b4478ad9746e65f29cb2881a36e05f57d51fc30 /net/xwhois/Makefile
parent913a23d2a9d9daa1d775000f3c958f34abca0e4b (diff)
downloadfreebsd-ports-gnome-7f1964c4d8f32942c731b19cb84ffcfb0c02a651.tar.gz
freebsd-ports-gnome-7f1964c4d8f32942c731b19cb84ffcfb0c02a651.tar.zst
freebsd-ports-gnome-7f1964c4d8f32942c731b19cb84ffcfb0c02a651.zip
Upgrade to 0.3.3
Diffstat (limited to 'net/xwhois/Makefile')
-rw-r--r--net/xwhois/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/net/xwhois/Makefile b/net/xwhois/Makefile
index 469f4410f236..bd590d3a049f 100644
--- a/net/xwhois/Makefile
+++ b/net/xwhois/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: xwhois
-# Version required: 0.2.9
+# Version required: 0.3.3
# Date created: 31 December 1998
# Whom: Kris Kennaway <kkennawa@physics.adelaide.edu.au>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/01/29 23:44:22 billf Exp $
#
-DISTNAME= xwhois-0.2.9
+DISTNAME= xwhois-0.3.3
CATEGORIES= net
MASTER_SITES= http://c64.org/~nr/ \
http://www.goatnet.ml.org/ \
@@ -14,22 +14,24 @@ MASTER_SITES= http://c64.org/~nr/ \
ftp://c64.org/pub/nr/xwhois/ \
ftp://ftp.infodrom.north.de/pub/unix/gtkbuffet/apps/xwhois/
-MAINTAINER= kkennawa@physics.adelaide.edu.au
+MAINTAINER= kris@FreeBSD.ORG
-LIB_DEPENDS= gtk11.1:${PORTSDIR}/x11-toolkits/gtk11
+LIB_DEPENDS= gtk11d.1:${PORTSDIR}/x11-toolkits/gtk11-devel
USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk11d-config
do-install:
-
- ${INSTALL_PROGRAM} ${WRKSRC}/xwhois ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xwhois ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/xwhois
${MKDIR} ${PREFIX}/share/xwhois/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/xwhois.servers ${PREFIX}/share/xwhois
- ${INSTALL_DATA} ${WRKSRC}/xwhois.xpm ${PREFIX}/share/xwhois/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/docs/xwhois.servers ${PREFIX}/share/xwhois
+ ${INSTALL_DATA} ${WRKSRC}/docs/xwhois.xpm ${PREFIX}/share/xwhois/pixmaps
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/xwhois
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xwhois
+ ${INSTALL_DATA} ${WRKSRC}/docs/TODO ${PREFIX}/share/doc/xwhois
${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/xwhois
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/xwhois
.endif