aboutsummaryrefslogtreecommitdiffstats
path: root/net/zebra-pj/files
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2001-01-12 05:45:05 +0800
committerandreas <andreas@FreeBSD.org>2001-01-12 05:45:05 +0800
commit234faae017022e10c97f32cae178c4143a630be1 (patch)
treeb55b44695dd0fd1cf6a023e37efb0d382a03ab74 /net/zebra-pj/files
parentd782bd5d123360eb52bd6cb2d20ec18158687935 (diff)
downloadfreebsd-ports-gnome-234faae017022e10c97f32cae178c4143a630be1.tar.gz
freebsd-ports-gnome-234faae017022e10c97f32cae178c4143a630be1.tar.zst
freebsd-ports-gnome-234faae017022e10c97f32cae178c4143a630be1.zip
upgrade to new zebra version 0.90
- removed PORTREVISION (new version) - new configure script: dialog menue allows you to set different zebra compile time options (if ! BATCH), currently supported: --with-libpam = enable PAM authentication for vtysh --enable-nssa = enable OSPF NSSA --enable-snmp = enable SNMP support - please note: port compiles fine when all options are set, but functionality has not been tested by me. - silence portlint, trim pkg-comment to <=70 columns - remove unneeded patch patch, 0.90 now contains fix for memory leak - cosmetic: add patch for Makefile.in (don't link with -g) - portlint: o.k. In this BETA --enable-unixdomain and --enable-newrib became default ! To get old implementation back use the following configure options: --enable-tcp-zebra # TCP/IP socket is used for protocol daemon and zebra. --enable-oldrib # Turn on old RIB implementation. Note: I didn't add these options to configure script, so that people don't choose the wrong thing ! Some milestones of this release (see file NEWS for complete list): - access-lists can have remarks - memory leak with access-list and prefix-list name fixed - UNIX domain socket server of zebra protocol is added - PointoPoint interface network bug fixed - Metric value is reflected to kernel routing table - New RIB implementation has been added: - BGP passive peer support problem is fixed - Redistributed IGP nexthop is passed to BGP nexthop - Fix bug of holdtimer is not reset when bgp cleared - BGP-MIB implementation is finished - When BGP connection comes from unconfigured IP address, close socket immediately. - BGP flap dampening feature is added * RIP - Fix bug of refreshing default route * OSPF - Fix bug of Hello packet's option is not properly set when interface comes up - Reduce unconditional logging - New command for virtual-link configuration - Memory leak related classfull network generation is fixed
Diffstat (limited to 'net/zebra-pj/files')
-rw-r--r--net/zebra-pj/files/patch-001_vty_memory_leak18
-rw-r--r--net/zebra-pj/files/patch-zebra_Makefile.in15
2 files changed, 15 insertions, 18 deletions
diff --git a/net/zebra-pj/files/patch-001_vty_memory_leak b/net/zebra-pj/files/patch-001_vty_memory_leak
deleted file mode 100644
index c857fedf984f..000000000000
--- a/net/zebra-pj/files/patch-001_vty_memory_leak
+++ /dev/null
@@ -1,18 +0,0 @@
---- lib/vty.c.orig Tue Sep 26 23:03:12 2000
-+++ lib/vty.c Tue Dec 26 23:18:00 2000
-@@ -1850,10 +1849,13 @@
- printf ("line: %s\n", buf);
- #endif /* VTYSH_DEBUG */
-
-+ vty_ensure (vty, nbytes);
-+ memcpy (vty->buf, buf, nbytes);
-+
- /* Pass this line to parser. */
-- vty->buf = buf;
- ret = vty_execute (vty);
-- vty->buf = NULL;
-+
-+ vty_clear_buf (vty);
-
- /* Return result. */
- #ifdef VTYSH_DEBUG
diff --git a/net/zebra-pj/files/patch-zebra_Makefile.in b/net/zebra-pj/files/patch-zebra_Makefile.in
new file mode 100644
index 000000000000..47c586510848
--- /dev/null
+++ b/net/zebra-pj/files/patch-zebra_Makefile.in
@@ -0,0 +1,15 @@
+--- zebra/Makefile.in.orig Thu Jan 11 11:22:36 2001
++++ zebra/Makefile.in Thu Jan 11 11:23:00 2001
+@@ -331,10 +331,10 @@
+
+
+ zebra : $(zebra_OBJECTS) $(otherobj) ../lib/libzebra.a
+- $(CC) -g -o zebra $(zebra_OBJECTS) $(otherobj) ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
++ $(CC) -o zebra $(zebra_OBJECTS) $(otherobj) ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
+
+ client : client_main.o ../lib/libzebra.a
+- $(CC) -g -o client client_main.o ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
++ $(CC) -o client client_main.o ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
+
+ install-sysconfDATA: $(sysconf_DATA)
+ @$(NORMAL_INSTALL)